Problems with 2nd SSD as storage

Dear all,
registration and directly an ask for help :slight_smile:

I’m from Germany, and have not much aka non knowledge about Linux, Dockers aso. So, perfect for installing Nextcould on openmediavault via portainer on a Lenovo m70q… (Not for Backup, currently only in LAN)

As far, everything worked out well and I made it to the point that I have access to NC Hub 4.0 and already synced data, yeah.

I have 2 SSD in my m70q:
2 TB NVME for OMV (dev/nvme0n1p1-p3, 30 GB) and free rest (via gparted) mounted in OMV as storage (dev/nvme0n1p4)
4 TB SATA for storage (dev/sda1)
Both mounted in /srv/… (a problem?)
When I look no into NC-Admin settings, HDD Storage amount only shows 30 GB, probably from from OMVs drive (nvme0n1p2). And more than 30 GB is not syncable… already locked my webGUI but solved it…

I wished that the 4 TB drive would be used for NC. That’s my Problem. (Besides that Win Client is syncing slowly as… only 10% from available speed. Will be next question :slight_smile: )

What I already did is changing the editor file from I used:

  • I mkdir nextcloud with sub folders app, and database (also daten, but not in use)
  • put those folders in portainer editor: - /sda1/nextcloud/database:/var/lib/mysql and - /sda1/nextcloud/app:/var/www/html

But data still not landing on the 4 TB. What did I do wrong? Shall I some how say portainer, that it should go there? Im lost, totally lost :slight_smile:

Maybe someone has a bit time to give me a hint what to do next. That would be awesome!

Thank you, Seb

Currently running in portainer (Anything else missing?):

version: ‘2’

image: mariadb:10.5
restart: always
command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW
- /sda1/nextcloud/database:/var/lib/mysql
- MYSQL_DATABASE=nextcloud
- MYSQL_USER=nextcloud

image: nextcloud
restart: always
- 8080:80
- db
- /sda1/nextcloud/app:/var/www/html
- MYSQL_DATABASE=nextcloud
- MYSQL_USER=nextcloud

in addition:
The folders are filling now on sda1, but also the omv sys drive… when capacity reached there no sync is possible anymore :frowning: Do I need to tell portainer to not store the data, only move it to destination on host system?

ok, now working.