Problems to connect my nextcloud with my Android 7

My Nextcloud 11 0.2 on Ubuntu : 16.04.2 LTS, nginx, mariadb, php7.0
nextcloud virtualized on XenServer

My cloud works: But I have Problems, to connect my mobile Samsung Galaxy S7 with Android 7. My certificate ist created with letsencrypt an when I had Android 6 three weeks ago, all worked find. But now:

  • I don’t have any contact on my mobile
  • I don’t have no calendars on my mobile

Whiy? I think, my certificate, which was created with letsencrypt is blocking my mobile Connection:

  • I installed Nexcloud on my mobile without Problems. If I synchronize my local directory, I get the message: " “Die Operation kann nicht abgeschlossen werden, der Server ist nicht erreichbar: in english: operation could not finish, Server is not available”.
  • I installed DavDroid. Trying to connect to my contacts or calendars (organized in Outlook) I get Errors.
    -> (x) mit URL und Benutzername anmelden: (logging in with username:)
    .> error: “Ressourcen-Erkennung: es konnte weder ein CALDAV, noch ein CardDAV-Dienst gefunden werden” (english: there is no caldav and no carddav Service availavble).

If I check the protocol, then I see:

[HttpClient&1] <-- HTTP FAILEd. SSL handshake aborted: ssl=0x6ff0c97e00 i7o-Eerror during System call, Connection reset by peer.

I would think, that my certificate does not permit me to connect…
Googled, I found: ./var/www/letsencrypt/.well-known
This directory is empty. I would guess: there should be dontents in it, isn’t it?

What can I do? Any ideas? Thank you for your help, Sven

Hi. I tested
2 different nextclouds with calendar and contact-app
DAVDroid installed

  • path for my calendar in nextcloud with username and Password given

-> it worked
on Android 4.4.2
on Android 6
on iPhone

@nextcloud and bitfire: Pleeeeeease help :slight_smile:

I have also LetsEncrypt certificates for NextCloud, but on my mobile (running 7.0.1) the NextCloud app works. I don’t use CalDav with NextCloud since I store those on my own mail server.

Thank you, all except CalDav worked fine for me, too. But I now solved my problem:

I had to change this file and restarted nginx-service.

my changes:
I commented out this line:
ssl_ecdh_curve secp384r1;
and inserted this line:
ssl_ecdh_curve prime256v1;
afterwards: service nginx restart
Done, it works fine.
Thank you, Kind regards, Sven

Thank you, great solution That works for me to.