Problems setting up nextcloud-spreed-signaling

Hello!
I installed nextcloud-spreed-signaling with the docker-compose file.
I set up the parameters in the server.conf as explained to:
nats://localhost:4222
ws://localhost:8188
server=turn:localhost:3478?transport=tcp

The problem is it does not work.
At the signaling server I get:
Error: The server answers with 403

What I did wrong?
Which ports I need to open that it will work?

I set up the following secrets to random keys (all 3 the same random key for simplification):

  • internalsecret (sessions)
  • secret (backend)
  • secret (turn)

I use nextcloud version 19.0.2

You can look at this tutorial this would be with docker https://markus-blog.de/index.php/2020/11/20/how-to-run-nextcloud-talk-high-performance-backend-with-stun-turnserver-on-ubuntu-with-docker-compose/
or this thats the one I used
https://markus-blog.de/index.php/2020/07/30/how-to-install-nextcloud-talk-high-performance-backend-with-stun-turnserver-on-ubuntu/

Hello!
II was following your links now, but the issue persists.
I get the error 403 at the High Performance Signaling Settings at my nextcloud instance.
Its does not matter if I try it from external or even on the localhost with the correct path at /etc/hosts/.
Moreover I need the reverse Proxy Config for apache.
Can it for testing purposes be used with http directly through 8188, I was just opening the port 8188 to the outside and tryed it without any reverse proxy yet.

I wouldn’t use apache at all instead I would use NGINX for everything.
The config for NGINX is in the tutorial, both of them.

The problem had been soluted.
I figured it out :slight_smile:
Thank you for your help :slight_smile:

Could you please describe your solution to the community and me. I struggle with an similar error and would know how did you solve it.

Thanks!

Pete

That soluted my problem: