Problems setting up nextcloud-spreed-signaling docker-compose

Hello!
Can someone tell me where I can find the logs of the signaling standalone server?
I use the docker version with docker-compose.
I get 403 if I try to access ws://localhost:8188 and if I configure apache according to the manual here:

I get from outside with the shared secret also 403.
stun and turn work without issues but the high performance backend (signaling) does not.
Can someone advise?
best regards

Hi. Try to look at syslog.
ws://localhost:8188 is MCU (Janus) link. If you configured apache as in manual, signaling server must be at 443 port

Thank you very much
Is there a way how I can checkout if the signaling server itself is working locally on my server as I use the docker container, before I forward it through the reverse proxy?

I stepped on this rake a week ago :grinning:. If your /etc/signaling/server.conf is like
[http]
listen = 127.0.0.1:8080
then you can check server locally by
curl -i http://127.0.0.1:8080/api/v1/welcome
But there’s one moment. If your reverse proxy not on the same server, then you need to set listen parameter to interface IP address (not localhost) or signaling server wouldn’t response to proxy.

thanks that did work xD
After updating my site-settings at apache all works fine now.
Thank you very much :slight_smile:

The only thing weird is that it says version “unknown”. Is that a normal behaviour?

{"nextcloud-spreed-signaling":"Welcome","version":"unknown"}

+ If the tester at the talk settings says: OK, version:unknown its ok as well?

That is out of my knowlege. I think, it’s not normal, but if everything works, than it’s OK :slightly_smiling_face:

Thank you very very much, it works like charm :slight_smile: