Problems mounting external files using the external files app

Okay so I had a folder called “Work” mounted to my main SSD drive, but decided to move all my work files onto a second HDD drive. At first it seemed to be syncing correctly but now when it won’t and when I check it in the settings it always shows me this:

But this is the correct address as you can see here:

I’ve also got a symlink from this folder to my Home folder, and I’ve tried mounting that symlink using /home/david/Work but that hasn’t worked either. It seems like it should work since my media folder does work and that is a symlink in my home folder that goes to another HDD drive.

So what’s the deal?

Permissions shouldn’t be an issue because I’ve added www-data to the david group, and david to the www-data group and I’ve set both of them to have default permissions etc of create and delete for all group members etc. 775 etc.

Hey just wanted to let people know I fixed this issue by adding my newly mounted file to the fstab list. It wasn’t mounting automatically when the computer rebooted so that was through off nextcloud. Thanks guys!