Problems mounting Amazon S3 compatible external storage as user instead of admin identity

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.0
Operating system and version (eg, Ubuntu 20.04): centos 7.6
Apache or nginx version (eg, Apache 2.4.25): nginx 1.20.4
PHP version (eg, 7.4): 7.4

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):Y

Steps to replicate it:

  1. I added Amazon S3 external storage as a user on the settings page, and I actually used Tencent Cloud COS object storage, but I tested it before and it was no problem.
  2. After entering the information, the server successfully connected to the bucket.
  3. Going back to the “Files” page, I don’t find the folder for external storage, but on the “External Storage” page I can find my storage policy.