Problems after changing password

Worked as a charm until I’ve set up 2FA. I have only message “An error occurred while setting up the account” now. I’ve removed saved password from database but no joy, tried to leave message on forum but some ngix error only displayed (some other issue) Please advice.

When you enable 2FA you have to use app specific passwords for clients. If I understand your question, the error message is coming from a client?
Try going to Personal, then setting up an app password for that client and see if you’re able to connect with that.

Yes, the message is in client. I cannot find any information in log file, not sure, where I should be looking.
I’ve removed the stored password in Thunderbird password manager, set a new app password in Nextcloud Personal page and revoked access in Nextcloud->Personal->Sessions. I remember, I had excactly the same problem when I only changed the password in the past, only way I’ve managed to sort this out was to completely remove Thunderbird personal folder and start from scratch.

I’m not sure if this will help, but the Nextcloud Filelink readme on their github page says that it’s a known issue where you need to remove and recreate the account if you change the password.

I have done everything I can think of, including step on github “You cannot edit your Filelink account. You have to delete and re-create it if you need a change (password, folder, link password, port, etc.)”:

  • Thunderbird: removed filelink provider
  • Thunderbird: un-installed Nextcloud/Owncloud Filelink add-on
  • Thunderbird: removed password for my host
  • Nextcloud - created a new app password
  • Nextcloud - revoked session stored for Nextcloud
    In Nextcloud log I have login failed. The app password works with desktop sync client and android client ok. Finally I’ve tried to login using standard password and this what I have instead:

Hi linucksrox, I’ve just manually upgraded the filelink extension from github to version 1.5 and it works now fine. Cheers.

That’s good to know, thanks for the update!