Problème avec l'https et reseaux public

Bonjour,
Je suis débutant sur Nextcloud.
Il me reste plusieurs erreurs que je ne parviens pas à corriger la première, c’est le https j’ai utilisé Let’s Encrypt.
Voici l’erreur :

>  (Domain: MON DOMAIN
>    Type:   connection
>    Detail: Fetching
>    http://MON DOMAIN/.well-known/acme-challenge/Y7vk3_PlREf12varIa4D53QZdkECOlwLxmlZNWflufY:
>    Timeout during connect (likely firewall problem)
> 
>    To fix these errors, please make sure that your domain name was
>    entered correctly and the DNS A/AAAA record(s) for that domain
>    contain(s) the right IP address. Additionally, please check that
>    your computer has a publicly routable IP address and that no
>    firewalls are preventing the server from communicating with the
>    client. If you're using the webroot plugin, you should also verify
>    that you are serving files from the webroot path you provided.)

Si j'ai bien compris, c’est lier avec, c’est erreur :
> ( * La configuration du serveur web ne permet pas d'atteindre "/.well-known/webfinger". Vous trouverez plus d'informations dans la [documentation](https://docs.nextcloud.com/server/21/go.php?to=admin-setup-well-known-URL).
> * La configuration du serveur web ne permet pas d'atteindre "/.well-known/nodeinfo". Vous trouverez plus d'informations dans la [documentation](https://docs.nextcloud.com/server/21/go.php?to=admin-setup-well-known-URL).
> * La configuration du serveur web ne permet pas d'atteindre "/.well-known/caldav". Vous trouverez plus d'informations dans la [documentation](https://docs.nextcloud.com/server/21/go.php?to=admin-setup-well-known-URL).
> * La configuration du serveur web ne permet pas d'atteindre "/.well-known/carddav". Vous trouverez plus d'informations dans la [documentation](https://docs.nextcloud.com/server/21/go.php?to=admin-setup-well-known-URL).

J'ai pourtant bien modifier le fichier .htaccess : 

# Generated by Nextcloud on 2021-09-05 20:16:07
# Section for Apache 2.4 to 2.6
<IfModule mod_authz_core.c>
  Require all denied
</IfModule>
<IfModule mod_access_compat.c>
  Order Allow,Deny
  Deny from all
  Satisfy All
</IfModule>

# Section for Apache 2.2
<IfModule !mod_authz_core.c>
  <IfModule !mod_access_compat.c>
    <IfModule mod_authz_host.c>
      Order Allow,Deny
      Deny from all
    </IfModule>
    Satisfy All
  </IfModule>
</IfModule>

# Section for Apache 2.2 to 2.6
<IfModule mod_autoindex.c>
  IndexIgnore *
</IfModule>

Encore une foi je ne sais pas si c'est lier, mais j'ai pourtant ouvert mes ports (Modem Proximus) et pris un domain duckdns, mais je ne parviens pas à accédé à l'interface Nextcloud hors de mon réseau local.

Merci d'avance de votre aide. N'hésitez pas me demande des infos supplémentaires.

Le plus facile, tu peux regarder dans les logs de ton apache s’il y a des informations quand tu accèdes http://MON DOMAIN/.well-known/acme-challenge/Y7vk3_PlREf12varIa4D53QZdkECOlwLxmlZNWflufY de l’exterieur.

S’il y a un truc, il faut regarder la configuration de apache. Si tu ne trouves rien du tout, il faut revoir la redirection (dans ce cas en http et https, donc ports 80 et 443).

1 Like

Bonjour,
J’avais effectivement oublié de changer le serveur name dans la configuration d’apache. J’ai pu supprimer les deux erreurs (/.well-known/webfinger) et (/.well-known/nodeinfo).
Mais par contre pour les autres rien. J’ai consulté les logs, mais rien qui me parait anormal.

Merci pour l’aide

Bonjour,
J’ai continué à chercher et j’ai réussi à corriger la plupart des erreurs, mais il me reste toujours ce problème avec Let’s Encrypt et surtout que je ne parviens pas à accéder au serveur de l’extérieur.
Ce que je ne comprends pas, c’est que je peux utiliser le domaine en local sans soucis, si je ferme les ports ça ne fonctionne plus. Donc je pense que là-dessus je n’ai pas fait d’erreur. Mais quand je me connecte en 4G sur mon téléphone, il ne parvient plus à trouver le serveur.
J’ai un Pi hole sur mon réseau local ça pourrait empêcher la connexion à distance ?