Problem with ONLYOFFICE

I have a little problem.

I’m running onlyoffice on a seperate VM with docker and it works fine.
So I decided to connect nextcloud with onlyoffice…

I wrote the URL of my Onlyoffice Community - Editor Server.

After that I’ll tried to edit a File in Nextcloud but there is an issue:

“ONLYOFFICE app not configured”

Can someone help me?

My Nextcloud is signed with an SSL cert. My DocumentServer/Community Server Onlyoffice - is not. But this should be okay or?

technical mixing ssl and plain connections work but recent browser are blocking that. either you enable ssl with the documentserver, or you put a proxy which can do ssl in between you and onlyoffice.

I tried to create an SSL connection on the documentserver but it didn’nt work.
If i tried to start it on Port 443 it was not available by accessing it through : https://mydocument


you need to create some certificates for your documentserver as described here:

1 Like

Thanks for your quick response!
But is this actually the Problem ? I mean nextcloud says : app not configured
This should not be a problem with the cert or am I wrong?

@Whit3Styler try smt crazy. Just open your DocumentServer in your browser like this: http://my-documentserver / https://my-documentserver

If the page tells you that your DocumentServer is running, try again to open a document.

This isnt a fix but in my case it helped solving this issue.


The problem can be resolved by switching Document Server to https (as dev0 wrote above)
It will help you to avoid Mixed Content (Your NC page loaded over HTTPS cannot load resources over HTTP from Document Server)

@ftaut Well I have a Community Server with a integrated Document Server. as you can see here at 4:04

Is that possible too or do I need the document server self standalone?

Hello @Whit3Styler
In this case you need to switch Community Server to https. How to perform it you may see in our helpcenter.

Thanks for your response!

I’m doing exactly this:

sudo docker run -i -t -d -p 80:80 -p 443:443
-v /app/onlyoffice/CommunityServer/data:/var/www/onlyoffice/Data onlyoffice/communityserver

Container is running.

root@rs-office:/tmp# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES552ad7814903 onlyoffice/communityserver “/bin/sh -c 'exec …” 3 minutes ago Up 2 minutes>80/tcp, 3306/tcp, 5222/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp,>443/tcp, 9888/tcp

Port is with a docker Proxy attached:
root@rs-office:/tmp# netstat -tupln | grep 443
tcp6 0 0 :::443 :::* LISTEN 7940/docker-proxy

If i’m trying to access my Site through https:

I’m able to connect now!
Now is one last question open:
How can I do this cert valid?

Okay so I did copy the Tutorial of onlyoffice

But that makes no sense:
"docker run -i -t -d -p 80:80 -p 443:443
-v /app/onlyoffice/CommunityServer/data:/var/www/onlyoffice/Data onlyoffice/communityserver"
to run the communityserver on 443:

sudo docker run -i -t -d -p 443:443
-v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver
for the document server on 443:

This dosen’t work because only on of them can bind to 443: at the same time :o:

yes, thats because you missed the part that you have to setup a bridge-networkt and no ports exposed at the documentserver

sudo docker run --net onlyoffice -i -t -d --restart=always --name onlyoffice-document-server \
        -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data \
        -v /app/onlyoffice/DocumentServer/logs:/var/log/onlyoffice \

so nextcloud is using the communityserver for editing documents and that works too.

perhaps you should get sleep :stuck_out_tongue:

yep u’r right :smiley:

Well it was just a command from the onlyoffice documentation

I installed onlyoffice on this way:
bash -ims false this should be install the document and community server right?

But without https so how can I do this?

I know this isn’t a forum for onlyoffice but it would be cool if someone know how to do this


What certificate did you use for signing your apache instance of nextcloud?

I used this tutorial for creating ssl certs:

I’ve used the same certs for my communityserver

Is this correct?