Problem with install Collabora online


#1

Hello,
I have install collabora online but It’s didn’t work.
Error log on nextcloud 12 : https://pastebin.com/FxhPGm35
I’ve been trying it for a day with several domain names.
But always the same result: nothing works.
Please help me…
I am on apache2 and I followed the official tuto to the letter (change only the sub-domain).
I’m on debian 9 with nextcloud 12.
Nextcloud is on the same machine as Collabora contener.
I don’t have a firewall.
Sometimes I have the default Debian page.
Sometimes I make a mistake thinking I don’t have the necessary authorization.( error 403 )
But still, nextcloud tells me to contact the admin to fix the problem… but the admin is me…

My apache2 virtualhost config ( I’m local with my hosts modified files ) so in http, not in https : https://pastebin.com/iBs2AFVk

Thank you very much for your help…:kissing_heart:
Ertuit

PS: I’m a little bit at the end of it, I can’t stand no more to see that it doesn’t work… sorry…
and…I am fench…


#2

full docker logs : https://pastebin.com/6EUrVJfR


#4

Maybe you also need to make sure that the /etc/hosts in the docker container is modified?

In general, I am not sure if telling Apache to forward/proxy between http and https is a good idea :wink:


#5

Hello,
Thank you for your answer:)
I managed to solve all the problems. But I still have one left.
In nextclouds logs, collabora me “refuses” my connection…
logs of collabora docker contener : https://pastebin.com/uK20XR11
nextcloud logs: https://pastebin.com/T6K6fNCN
Thank you for all your help :heart_eyes:
Ertuit


#6
Failed to connect to 192.168.0.20 port 9980: Connection refused

I think this says that nextcloud can not reach collabora. Is the docker container really reachable under this IP? Please run docker ps and look in the PORTS column. On my host with a working collabora instance I have 127.0.0.1:9980->9980/tcp there.


#7

I have
root@Erserveur# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
6f6a38eab195 collabora/code “/bin/sh -c 'bash …” 25 hours ago Up 4 hours 127.0.0.1:9980->9980/tcp agitated_feynman

Thank you :slight_smile:


#8

That looks correct, so the question is where the IP 192.168.0.20 comes from. Is it in any of your config files or in your /etc/hosts file? Can you reach collabora running in the docker manually, with your browser or curl to 192.168.0.20:9980 or 127.0.0.1:9980? I am just guessing around here. In general I think the tutorial assumes that both your nextcloud and you collabora instance are running on an ip and hostname that is reachable from everywhere.


#9

…The ip 192.168.0.20 is the ip of the server. I cannot reach collobora with my browser and, inside the docker contener I have that
root@19232d98b1ff:/# curl localhost:9980
curl: (52) Empty reply from server
root@19232d98b1ff:/# curl 127.0.0.1:9980
curl: (52) Empty reply from server
root@19232d98b1ff:/# curl 192.168.0.20:9980
curl: (7) Failed to connect to 192.168.0.20 port 9980: Connection refused
192.168.0.20 is the ip of the computer running docker and nextcloud.
Thank you :slight_smile:
Ertuit


#10

This makes sense, because docker is only listening on localhost.

Now, I think your nextcloud is making requests to the port 9980 which it should not do. Instead it should use the apache proxying which you configures. As admin in nextcloud, go to /settings/admin/richdocuments and make sure that the URL you give there is something like http://collabora.ertuit.fr/ and nothing with 9980.

If this is not the problem, I am out of ideas. As I said, the tutorial assumes that you do everything with real hostnames. Moreover, plain http instead of https might be a problem.