Problem with files from . Nextcloud 19.09

Nextcloud version (eg, 20.0.5): 19.9.1
Operating system and version (eg, Ubuntu 20.04): CentOS 7.9
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.6
PHP version (eg, 7.4): PHP 7.4

The issue you are facing:

I have a problem with hidden files on a resource connected via SMB. I have two instances of nextcloud production and test version 19.09. On the test instance files with . are visible while on the production instance not. I would like that on production instance was the same as on test instance. For testing I connected the same resource to two instances and the problem looks like this:


I checked permissions: nextcloud files, user to connected external resources, nextcloud configuration files, versions of all apps.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

No server logs (ERROR and CRITICAL)

One or more entries are hidden by the log level filter

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' =>
  array (
    0 => 'xxx',
    1 => 'xxx',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'xxx',
  'dbhost' => 'xxx',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'loglevel' => 0,
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'knowledgebaseenabled' => false,
  'skeletondirectory' => '/opt/nextcloud-skeleton',
  'enable_avatars' => false,
  'allow_user_to_change_display_name' => false,
  'enable_previews' => false,
  'default_language' => 'pl',
  '' => false,
  'has_internet_connection' => true,
  'maintenance' => false,
  'filelocking.enabled' => false,
  'overwrite.cli.url' => 'https://xxx',
  'overwriteprotocol' => 'https',
  'overwritewebroot' => '/',
  'htaccess.RewriteBase' => '/',
  'mail_smtpmode' => 'smtp',
  'trashbin_retention_obligation' => '7,8',
  'versions_retention_obligation' => '7,8',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'password' => 'xxx',
  '' => 'stable',
  'proxy' => 'xxx',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'xxx',
  'mail_domain' => 'xxx',
  'mail_smtphost' => 'xxx',
  'mail_smtpport' => '25',
  'mail_smtpauthtype' => 'LOGIN',
  'app_install_overwrite' =>
  array (
    0 => 'files_accesscontrol',

The output of your Apache/nginx/system log in /var/log/____:

In the lower left corner you will find the Settings dialog of the Files app where you can tick an option to get hidden files displayed :wink:

For testing, I connected the same resource to two instances. Showing the files does not solve the problem because the production instance does not see the hidden files.


If your production instance doesn’t show the files, it might most likely be a Samba specific setting which prevents displaying it. See e.g.

Thank you for your help I found a solution. On the production instance was used php-smbclient package while on the test instance was not found. Removing package php-smbclient or hash solved my problem.

1 Like