Problem opening and copying files thru webdav

Hi there,
I’ve setup nextcloud on a pine64 and things are running pretty great. In fact I’m really surprise to see how reactive and fast it all goes.
I’ve configure external storage, synced several devices with nextcloud desktop and everything is great on that part.
However, I’ve mounted my nextcloud in windows 10 (seemed to work) but when I’m trying to open or copy some large files and videos, it says that the file can’t be found.
Of course, the file is there and it can be open with a web browser, in the android app and synced with the desktop app.
I’ve checked everything I could think of and didn’t find anything relevant.
I’ve checked any file size limits I could find on any ini files.
The size limit seems to be 50MB.

Any infos on webdav size limits or something ?!

I would expected that WebDAV might be impacted by the usual PHP parameters upload_max_filesizeand post_max_size. Have you checked that too?

I’m running ubuntu 18.04.

I’ve checked /etc/php/7.2/apache2/php.ini and both parameters are set to 8192M

The other php.ini found in /etc/php/7.2/cli and fpm have both parameters set to 4096M.

However I don’t actually know which php.ini is being used when running nextcloud…

OK, here’s some more infos.
I’ve made other tests mounting my nextcloud on linux.
When doing so, I did get a message saying “/sbin/mount.davfs: warning: the server does not support locks”, but it all worked and I can open and copy large files.
So, the issue might be windows 10 related. Is it specific to my windows configuration ?
Could anyone make a quick test to confirm that ?

OK, I found the problem.
Windows default for file size thrue webdav is 50MB. This can be changed in the registery allowing to actually copy files larger than 50MB. However, the max file size is 4GB and it’s stilll pretty much unusable because when tou try to open a file, windows will copy the file locally, so you’re better of with the web browser.
If anyone still want to bother with it and change the default file size limit in the registry, you have to change: