Problem, my website is down ! Log File / App Installation

Hello everyone !
Today i was installing apps from the nextcloud appstore …

And after installing an app, my site tells me an error and is no longer accessible

The server is unable to execute your request.

If this happens again, please send the technical details below to the server administrator.

The server log file can provide more information.

Technical information
Remote address: 91.166.XXX.XXX
Application ID: XcXAI9ZzvRH0erjKaOjwRgAAALQ

I don’t know where found the log file and i want some assistance if you can help me :frowning:

Thank for your help !

Where has Nextcloud been installed, on a private server or in a hosting environment?

OVH Hosting @j-ed

Do you have a console access to you server? If yes, you should check the data directory, which you will find in your Nextcloud document root, and which is the default location of the log file.

It’s an OVH webhosting offer…

Don’t have any console … Only FTP and MYSQL

@j-ed * sorry

Eventually you can try to navigate through the directory structure and download the log file using FTP. If this is not possible, I would recommend to contact the OVH support and asked them for help.

@j-ed OVH can’t do anything i tought…

If i provide you in private the FTP login details, can you look into it to try to help me to find this log please ?

@j-ed I searched during 10 minutes without finding anything

Unfortunately I don’t know the OVH hosting solution. Better would be to wait for someone how knows the environment better than me.

BTW, have you subscribed to a ready-to-use Nextcloud service or have you installed Nextcloud on your own? In the first case OVH definitely nee to help you, in the second case you should know in which directory you’ve installed the software.

@j-ed UPDATE: I finally found the log file !

Can you help me to fix the problem ?

If you have discord you can maybe add me ? Archange226#5101

... "Exception":"Error","Message":"Class 'OCP\\Config' not found","Code":0,"Trace":[{"file":"\/home\/spacepvpde\/DRIVE\/apps\/files_reader\/lib\/Hooks.php","line":41

That exception is logged in your log file which points to the files_reader app causing a problem. As you can see here a pull request exists which hasn’t yet been applied to the latest app version:

Due to the fact that the files_reader app seems not to be compatible with Nextcloud 17, I would recommend to deactivate it. Unfortunately you don’t have console access and therefore you cannot run an occ command to deactivate it.

What you can try to do is, to move the app directory (./apps/files_reader) to a folder outside the Nextcloud document root and see if this fixes the problem. But I personally never did that and cannot guarantee you that it will fix the problem.

1 Like

I tried to move it and it doesn’t worked so i just… deleted it… and it’s still not working

@j-ed thank for your HQ support !

It worked after 5 minutes!

1 Like