Problem downloading files from Nextcloud

Hi everyone I have an annoying and strange problem

System Information
FreeNAS 11.1 U4
Nextcloud 13.0.2
PHP version 7.0.30
Storage: SMB

The problem is that I try to download files so the download gets stuck and after a minute - 30 seconds it fails
And the strange thing is that in my local network it can download most of the file (eg the file weighs 16GB so it downloads about 12GB and it changes all the time when it gets stuck)
And outside the network it can be stuck at the beginning in the middle or immediately (eg the file weighs 1GB so it can hang at 20 MB and it’s also here changes all the time)
I have no idea where to start checking and how to fix it and I do not think it is timeout because the time of PHP is high

PHP information
Version: 7.0.30
Memory limit: 512 MB
Maximum operating time: 3600
Maximum upload size: 16 GB

And upload files

I checked twice and managed to upload all 16 GB on the local network
And out of the network I was able to upload 4GB (I did not have time yet to check more than that)

And I thought maybe it would be better to mention it too
On the local network I download files on average at a value of 3.4Mb / s
And outside the network at 370 Kb / s

  • I also used my domain on both the local and outside the network

Thanks Itay

Hello help please!!!

Hi,

Could you please look for relevant log entries in your

  • Nextcloud.log
  • web server log
  • system log (/journal)

Nothing is written about the problem

Help please have someone who knows how to fix it or what the problem is because i am at a loss and do not know what to do anymore !!!

Thanks everyone for the help you really did not help

Hi @Itay1778, sounds like a nightmare problem you have there. You have my sympathy. The one thought I had, and it’s only a thought from an old brain. Have you tried using a NFS mount setup between Nextcloud and your FreeNAS service? Samba is a “data-dance” I like to avoid, if I can. My NFS (Jumbo frame) traffic to an ancient QNAP NAS box has never hick-cupped but then, none of my files exceed 4GB. If you want to give it a try, I can pass on a brief example to crib from.
à bientôt

Truly a problem of hell I’m at a loss already and I use Nextcloud almost every day.
And I would try it and anything else but also the files are considering much more than 4 GB I would also try local storage but the only thing I use in SMB is that I also want to roam within my local network on Windows computers directly access to the file explorer instead of the Nextcloud browser is only for external purposes that I use relatively A lot and with the option I had to switch from SMB I would do this but it is problematic so I need a solution that will solve this problem along with SMB

And I do not think it’s SMB because I copied a test file, to local storage and still the problem is there!

And thanks for your response and appreciate it very much

Nice to hear back from you @Itay1778. Sorry, I may be misunderstanding your long 2nd sentence, but here goes. Would I be correct in thinking that these monster gigabyte downloads are exclusively targeted at Windows systems? If so, have you thought of testing it on alternatives :wink: …? Perhaps a Mac or Linux machine wired into your LAN could reproduce the problem or maybe even demonstrate success.

Regarding Samba & NFS, I now lack experience of using Windows but I believe it is possible to define a network folder to Windows that uses the Webdav protocol. This can be directly mapped up to your Nextcloud user, but that is a question that’s best put to a Windows techie. In the past on “Dolphin”, my Linux file manager, I have been able to webdav into my home cloud-storage from abroad. So I don’t require SMB/CIFS to access my cloud data with the a standard file manager. In fact for additional security this NFS cloud data (share) is “hidden” on a dedicated NAS Ethernet port. Samba+FTP+Webdav (but not NFS) is supported on the other port of my QNAP NAS. Perhaps your FreeNAS has similar scope.
My new Nextcloud 13 system is still “work-in-progress” (i.e. broken) but if I get the opportunity and have the ability, I will attempt to reproduce your problem. At the very least, prove I can support files much greater than 4GB.
Stay positive, :moneybag: as my X kept trying to convince me.

I meant that I checked into the Nextcloud local storage (without SMB) and the problem was still there.
So SMB does not seem to be the problem

My test was that I copied a 5GB file and the problem was the same, there was no change exactly the same problem was

There is a possibility to use Webdav in Windows but it is unstable and there are problems with it (at least in Windows)

(Big Sigh)… When you look at the plethora of problems people are still reporting while uploading/downloading multi-mega-byte files, not just Nextcloud ones, it makes you despondent of ever finding out which “Gremlin” code is your battle with. The only other avenue you might want to explore is Apache2 settings. I recently purchased a book on Apache 2, only to be disheartened by the weight and it’s biblical number of pages.
If you could “run your problem” past an Apache guy, it would be worth a few beers (alas, probably virtual ones) to see if this is the culprit.
I wish you well my NC friend, and I regret that your solution-fix remains illusive.

Thanks for everything! I am currently in contact with Freenas forums and are trying to find a solution

Have you found a solution yet, I have the same problem?

The problem was in my router, I changed it and everything worked

1 Like

Thanks for this, I’m running my own router, changed a couple of settings and it worked.

?Pfsense? opnsense