Problem bei der Weiterleitung durch https

Moin moin!

Ich hoffe ihr könnt mir bei meinem Problem behilflich sein.
Die Nextcloud läuft stabil und ist lokal als auch aus dem Netz per Reverse-Proxy unter meiner Domain (sub.domain.de:port) per https erreichbar. Möchte ich mich allerdings über den Windows-Client anmelden, verweigert dieser die Anmeldung mit dem Hinweis

Die Polling-URL beginnt nicht mit HTTPS, obwohl die Anmelde-URL mit HTTPS beginnt

Als Warnung im Adminbereich erscheint folgendes:

Du greifst über eine sichere Verbindung auf deine Instanz zu, deine Instanz generiert jedoch unsichere URLs. Dies bedeutet höchstwahrscheinlich, dass du dich hinter einem Reverse-Proxy befindest und die Konfigurationsvariablen zum Überschreiben nicht richtig eingestellt sind. Bitte lese die Dokumentation hierzu ↗.

Diese ist, laut meinem Verständnis, auch die Ursache für mein Problem.

Bisherige Lösungsansätze:
Natürlich muss ich die config.php entsprechend dem reverse-proy noch einrichten - hier stoße ich allerdings an meine Grenzen…
Aktiviere ich " overwrite => https" ist zwar die Warnmeldung verschwunden und ich kann weiterhin (mit meinem angemeldeten) Adminkonto auf die cloud zugreifen, aber beim Versuch mich neu anzumelden oder beim Besuch der Startseite (Nextcloud-Logo in der linken oberen Ecke) bricht die Verbindung ab der Browser gibt folgende Meldung.

Diese Verbindung kann keine sichere Verbindung bereitstellen. 192.168.2.87 hat eine ungültige Antwort gesendet. ERR_SSL_PROTOCOL_ERROR

Lokal ist die Nextcloud gar nicht mehr zu erreichen.
Klar, das Zertifikat gilt ja auch nur für Zugriffe von außen und hier findet scheinbar eine direkte interne Weiterleitung statt - anstatt wie vorher zu meiner Domain schlüsselt der Browser nun auch zu “192.168.2.87:port/apps/dashboard”

Ich habe bereits durch try and error mit sämtlichen verschiedenen Kombinationen von trusted_domains/proxies, overwrite.cli.url, overwritehost, etc versucht das ganze zum Laufen zu bringen, aber ohne Erfolg…

Aktuelle config.php (mit dieser funktioniert der Zugriff per https im Browser, jedoch nicht über den Client)

‘trusted_domains’ =>
array (
0 => ‘192.168.2.87’,
),
‘trusted_proxies’ =>
array (
0 => ‘192.168.2.87’,
),
‘overwrite.cli.url’ => ‘http://192.168.2.87’,
#‘overwriteprotocol’ => ‘https’,
#‘forwarded_for_headers’ = [‘HTTP_X_FORWARDED’,‘HTTP_FORWARDED_FOR’],
#‘overwritehost’ => ‘’,

Infos zum System:

  • Bei welchen Anbieter? Was für ein Server? v-server, shared, root, usw. Oder Lokal? Lokal gehostet
  • Auf welcher Hardware? Asustor NAS
  • Betriebssystem sowie Version ALLER beteiligten Systeme:
  • Nextcloud Version: Hub 7 (28.0.1)
  • PHP Version: 8.2.14
  • Welche Datenbank? MariaDB (Asustor/10.7.3.r61)
  • Apache version: Apache HTTP Server (Asustor/2.4.55.r17)
  • Läuft NC in Docker
  • Netzwerk Aufgliederung: Router>Switch>NAS
  • Wurden vor kurzen Server Updates gemacht? Nein, Neuinstallation
  • SSL-Zertifikat von LetsEncyrpt und auf der NAS im Zertifikatmanager hinterlegt

Ich hab etliche Foren und Videos durchsucht und bin auch unzähligen Anleitungen gefolgt. Das Ergebnis ist bisher immer das gleiche: lösche ich den # vor ‘overwrite’ => ‘https’ ist die nextcloud nicht mehr erreichbar, egal welche weiteren Parameter ich eintrage und ändere…

Für Hilfe wäre ich wirklich sehr dankbar!

Gruß

Edit:
Auf der Suche nach einer Lösung bin ich bisher leider nicht fündig geworden.
Ich habe jetzt nochmal ein kurzes Video zur Veranschaulichung des Problems aufgenommen und den Titel des Threads bearbeitet.
https://youtu.be/MhFgdjpCio0