Prevent Nextcloud from changing ctime after uploading

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 24.0.9
Operating system and version (eg, Ubuntu 20.04): debian 11 bullseye
Apache or nginx version (eg, Apache 2.4.25): Apache
PHP version (eg, 7.4): PHP 7.4.33

The issue you are facing:
The file ctime is changed after uploading with desktop client Version 3.7.3 on Manjaro. This causes error messages when editing a file with neovim.

Is this the first time you’ve seen this error? (Y/N): I have seen it repeatedly after I started using neovim a lot in the last days.

Steps to replicate it:

  1. Pause sync
  2. Create a file and edit it in neovim: nvim Keep some unsaved changes.
  3. Check ctime: ls -lc
  4. wait for a few minutes, then enable sync
  5. after the file is edited, nvim will show W12 (Warning: File "{filename}" has changed and the buffer was changed in Vim as well)

As long as the nextcloud sync is disabled, I don’t see this error.

How can I present this behaviour? Can I disable an option to avoid changing the ctime?