Prevent copying huge files to /tmp before transfering to another Nextcloud instance

Nextcloud version (eg, 12.0.2): 16.04
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.29
PHP version (eg, 7.1): 7.2.24

The issue you are facing:
When trying to copy large files (> 100GB Prores movies), NC first copies the files from the original external mount (another HD) into the /tmp folder. This has 2 downsides, first it takes around 10 minutes to copy the file from one HD to another, second, the drive where the /tmp folder is, only has 300 GB, so during transfer the capacity of the system drive is severely diminished, which can limit other processes, potentially failing the copy operation because of lack of space in tmp folder

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. Mount external drive with large files
  2. Add Another NC instance as external remote mount
  3. Copy file from original external drive to remote NC server

Does this also happens is NC is being served via NGINX?
How can this behavior be disabled and files transferred directly from their locations to remote servers?

Did I understand it correctly? You have 2 external shares configured in NC and trying to copy files from external share A to external share B via WebUI?

One is an external server (another NC instance), the other is a local volume added using the external storage feature, but on the same server