Ports are open, but shown as closed in NCP

I installed NCP successfully on a RaspberryPi 3. I opened ports 443 and 80 manually in my FritzBox 7490 since the automatic port forwarding didnt work (don’t now why, the dot appeared red all the time) although I allowed UPnP in the Fritzbox. Everything worked, I had access from outside through No.IP and was abel to set up file sync with my mac.

Since yesterday the ports are shown as closed although I didn’t change anything in the settings. Does anybody know why that happened?

The ports are still open in the FritzBox. I restarted both systems several times. NCP still shows the ports as closed, the FritzBox as open.

Thank you for reading!

I checked, but could not reproduce this, ports show open for me.
NextCloudPi version v1.39.19

It has happened in the past (ports show closed, while in fact open), due to upstream changes in the way the ports are checked. But then everyone had the same problem, not so this time…
Do you still have access to NC via domain?
Can you run ncp-report and share output via pastebin service or txt file?

BTW How did you install? curl installer?

HEre is my System Report

|NextCloudPi version|v1.39.16|

|NextCloudPi image|NextCloudPi_11-27-20|
|distribution|Debian GNU/Linux 10 \n \l|
|USB devices|sda|
|data in SD|no|
|data filesystem|btrfs|
|data disk usage|22G/30G|
|rootfs usage|2.4G/15G|
|Nextcloud check|ok|
|Nextcloud version||
|HTTPD service|up|
|PHP service|up|
|MariaDB service|up|
|Redis service|up|
|HPB service|down|
|Postfix service|up|
|internet check|ok|
|port check 80|closed|
|port check 443|closed|
|NAT loopback|no|

I attached also a picture showing that the FritzBox is keeping the ports open.

I don’t have acces via domain.

I installed it by downloading the NextcloudPi Image from OwnYourBits. Then flashed a SD-Card via Elena Batcher.

I don’t work with the terminal just with the UserInterface that comes with the installation.


Bildschirmfoto 2021-10-01 um 17.51.55


I erased the Pi from the UPnP list in the FritzBox and added it again. Now it works. It was a FritzBox bug.

1 Like

You btw should not use upnp for that, better disable it on the fritzbox. It is a security risc. Either use upnp to forward the ports and then disable it afterwards, or set up the pirt forwarding manually, which is the recommended way.