pico-CMS does not do anything

Hi,
I am struggling to get the pico-cms integration to work. Installation seems fine. IIUC I need to put the line

RewriteRule /sites/(.*) https://mynextcloudpath/index.php/apps/cms_pico/pico/$1 [QSA,L]

in my nextcloud directories .htaccess (shared host)
Of course there is a .htaccess which makes things a bit more complicated but I assume that it must go in this section:

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{HTTP_USER_AGENT} DavClnt
  RewriteRule ^$ /remote.php/webdav/ [L,R=302]
  RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
  RewriteRule ^\.well-known/host-meta /public.php?service=host-meta [QSA,L]
  RewriteRule ^\.well-known/host-meta\.json /public.php?service=host-meta-json [QSA,L]
  RewriteRule ^\.well-known/webfinger /public.php?service=webfinger [QSA,L]
  RewriteRule ^\.well-known/nodeinfo /public.php?service=nodeinfo [QSA,L]
  RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L]
  RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L]
  RewriteRule ^remote/(.*) remote.php [QSA,L]
  RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
  RewriteCond %{REQUEST_URI} !^/\.well-known/(acme-challenge|pki-validation)/.*
  RewriteRule ^(?:\.|autotest|occ|issue|indie|db_|console).* - [R=404,L]
  RewriteRule /sites/(.*) https://mynextcloudpath/index.php/apps/cms_pico/pico/$1 [QSA,L]
</IfModule>

despite the fact that in the .htaccess it says some lines bellow:

DO NOT CHANGE ANYTHING ABOVE THIS LINE

After doing that the installation still won’t work. It just does not do anything … I can setup new pages - put a name, an address - I CANNOT choose a folder - it says “/” and nothing else. When I hit “create page” (I assume - I am not using the english version) NOTHING happens

any idea what is wrong?

best regards

Hi @daniu,

you don’t have to configure the .htaccess to have a working App, it is only for having shorter URLs. Does your Pico CMS-App work without the customisation of .htaccess?

Nonetheless, you should follow the the instruction by your webspace provider to not change anything above the line. Just put the lines for Pic-App below it:

[...]

DO NOT CHANGE ANYTHING ABOVE THIS LINE

RewriteEngine On
RewriteRule ^/sites/(.*)$ https:///mynextcloudpath//index.php/apps/cms_pico/pico/$1 [QSA,L]

But as this doesn’t seem to be the main problem:

What settings did you make in your admin setting ( …/settings/admin/cms_pico)? Have you enabled designs and templates?

Hi,
no - I did not adjust those values in the admin setting. Do I need to do that?
regards

There has to be at least one enabled design and template. I can’t recall if the the ones the app ships with are enabled by default, but I think i had to do that manually.

the problem is that in the settings I cannot choose anything either …

Either you are in your Personal settings and not in the Admin settings - there is a Pico CMS section in both of them. Or the app installation didn’t succeed and you should reinstall the app.

Hi,
I did not say that there is no admin settings section. There is.
However the select boxes in there are empty and I cannot select anything.

I tried to uninstall the app and delete it manually from the server and reinstall it. That did not change anything. Do I need to do more to get rid of any fractions of the app?

I do have problems at times with self filling log files that exceed my quota so that the server might indeed not finish the installation properly. At the last installation attempts however I definitely did not have that problem

I even checked the html for the first select box:

<td class="left">Neues benutzerdefiniertes Design hinzufügen:<br>
			<em class="admin_cms_pico_refresh" style="cursor: pointer;">Refresh if you cannot find your new folder</em>
		</td>
		<td class="right">
			<select id="admin_cms_pico_new_themes" class="field250">
			</select>
		</td>

empty select box …

the other one looks exactly the same