PHP8 support soon? (Update: PHP8.0 supported already, I'm an idiot)

Since PHP8 is recommended for 23, will Twofactor-TOTP support it in the near future?

Hi @Kraligor

Both Netxloud and the TOTP app work fine with PHP 8.0. PHP 8.1 however, is not yet supported, but will most likely be with v24…

Hopefully. Ubuntu 22.04 LTS will be shipped with PHP 8.1. :wink:
Ubuntu – Details of package php in jammy

1 Like

it’s not recommended. 7.4 is recommended. Though it works with 8.0. just to be precise :wink:

1 Like

Yes otherwise there will be even more posts here from people having issues after the upgrade. than there will be anyway :wink: But normally the update to a new Ubuntu LTS version is offered only after the first point release. Before that you have to force the update with do-release-upgrade -d, but of course that won’t stop everyone from upgrading on day one. :wink:

Yes. But on new install between release of Ubuntu 22.04 LTS and the first point release the most admins install Ubuntu 22.04 LTS and not the old Ubuntu 20.04 LTS.

True. Didn’t think about that.

Hey thanks so much for the answers! :slight_smile:

It was a bit late last night, so my brain was at 50% or so…

I’m running Arch which ships PHP8.1 (I guess the Nextcloud in the repo is modified so it works with 8.1). The info.xml of twofactor_totp says indeed <php min-version="7.3" max-version="8.0" />, so that explains why I’m having issues installing it. I guess I was just confused because in the Nextcloud Appstore it says PHP with a version lower than 8.0 is required.

So I’ll just wait for V24 to drop and twofactor_totp to support PHP8.1.

I don’t want to nitpick (especially since I’ve been wrong about the app not supporting PHP8 :wink:), buuut… the documentation for V23 explicitly says PHP Runtime 8.0 (recommended).

1 Like

you are right and it’s good that you have been nitpicking, apparently. I looked at exactly that page some time ago and was sure that there was a recommendation for php 7.4 … well done! Thanks for this information

1 Like


Has anyone got a guide to update to PHP V8 from V7.4. I have been looking and can’t find anything.

Want to update to NC V24 from V23 and one of the apps requires PHP8.0 As a min.

Thanks for your help.

Normally you upgrade your operating system and then you get the correct version
What dou you use? Ubuntu? Which version?

If you use Ubuntu, upgrade from Ubuntu 20.04 LTS to Ubuntu 22.04 LTS and you get the correct PHP version (here PHP 8.1), too.

If you read system requirements there is a problem:
Ubuntu 20.04 LTS (recommended)
8.0 (recommended)

That does not belong together.
Ubuntu – Informationen über Paket php in focal (Ubuntu 20.04 LTS with PHP 7.4)
Ubuntu – Informationen über Paket php in jammy (Ubuntu 22.04 LTS with PHP 8.1)

If you use the documentation you must install PHP 8.0 from a third party e.g. PPA. However, I would not do that. I would upgrade to Ubuntu 22.04 LTS and use PHP 8.1. Maybe someone can change the documentation. Thanks.

Hello, Sorry for the late reply, I’m using truenas. So FREEBSD.

As I have been playing I have V23 working on PHP8 but when I update to V24 PHP7.4 pops back.
I am using the truenas GUI Updator and from the log it’s pulling it back to 7.4. So at a later stage I’ll update it in nextcloud GUI at the moment it’s stuck in stage 3 update but everything still runs fine, just no updater.
I’ll sort this out when I have a bit more free time.

Thank you. For your reply.

Sorry i do not know FREEBSD.

But to every operating system version belongs a php version.
Either you increase the operating system (and thus indirectly php) or you have to install php from a foreign source.

Post more details. Maybe someone can help you.