Php7.2 doesn't start on RPi3


I’ve been trying to install Nextcloudpi using ready-made image as well as curl. I’m able to boot and access ncp-config. However, when I try to access WebUI, it fails. I checked apache2 and it’s up, php7.2-fpm failed to start.
When I try to do nc-init, it gives me a lot of “illegal instruction” errors.

sudo ncp-report:
journalctl -xe :

Welcome @HighWatersDev and thanks for reporting
Curl installer still has some bugs presently, better stick to the images, docker and/or VM for now.

Could you please also pastbin output of

sudo /usr/local/bin/ncp-report

@HighWatersDev Illegal instruction means that you are on an armv6 pi, and that is currently not supported

@OliverV yesterday I tried the curl installer and it worked :confused:

Thanks fellas!

It is true, it was armv6 that was causing the issue. I initially was having problem when RPi power supply wasn’t good enough and it was causing the errors. I replaced the power supply but experiencing the issues. I finally replaced RPi3 with a newer version and it worked just fine.

Thanks again for taking a look at it.