PHP upload size since 16.0.x

Nextcloud version (eg, 12.0.2): 16.0.2
Operating system and version (eg, Ubuntu 17.04): Ubuntu Server 19.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.38
PHP version (eg, 7.1): PHP-FPM 7.2

The issue you are facing:
After the last two upgrade (15.0.6 -> 16.0.1 - > 16.0.2) my php settings for uploading big files in .htaccess and .user.ini were gone. Admin site showed a warning that upload size is less than 512M. Also the input box in the admin gui is gone since 16.0.1?!
In 16.0.1 I solved this by editing file via ssh. Same works in 16.0.2 too, but itegrity check failed (obviously) due to hash check of edited files.

Is this the first time you’ve seen this error? (Y/N): Y

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

{
    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "toothless.goip.de",
            "toothless.fritz.box",
            "toothless.spdns.de"
        ],
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "16.0.2.1",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "enable_previews": false,
        "skeletondirectory": "",
        "logtimezone": "Europe\/Berlin",
        "log_type": "file",
        "logfile": "\/var\/log\/nextcloud\/nextcloud.log",
        "loglevel": 1,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 6379
        },
        "htaccess.RewriteBase": "\/",
        "filesystem_check_changes": 1,
        "mail_smtpmode": "smtp",
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": true,
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": 587,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpsecure": "tls",
        "knowledgebaseenabled": false,
        "force_language": "de",
        "force_locale": "de_DE",
        "data-fingerprint": "92f2dc7cc6a0d63fcdb2eaf4c81b51f0",
        "maintenance": false,
        "theme": "",
        "overwrite.cli.url": "https:\/\/toothless.goip.de",
        "app_install_overwrite": [
            "occweb"
        ]
    }
}

Hi,

I believe this was an intended change. With every update the modified settings were overwritten due to the fact that an NC upgrade replaces the hole NC folder.
So since NC16 the global PHP settings regarding upload size come into account and need to be modified as desired.

Look for the php.ini under /etc/php*. There should be a folder for cli (wrong one) and a folder for apache I believe. You need to edit the php.ini in the apache sub folder or in the general (not cli) directory.
Search for the following parameters and enter the desired max file size for uploads:

upload_max_filesize = 20G
post_max_size = 20G

Okay.
In NC 15 and below global php ini‘s were not in account, at least for nextcloud‘s check on admin site. Never tested if upload limit are increased in lower versions.

I will test with NC16 again. Will the check on admin site be passed with settings in global php ini?

If I understand your question correctly: yes. The admin site will show what you configured in the global php.ini.

Thanks. I will try.