PHP-OPcache - Fragen zur Konfiguration

Hallo,
Nextcloud 12 bemÀngelt in der Konfiguration den OPCache:

Der PHP-OPcache ist nicht richtig konfiguriert. FĂŒr eine bessere Leistung empfiehlt es sich folgende Einstellungen in der php.ini vorzunehmen:

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

Leider kann ich bei meinem Provider (HostEurope, Webserver Medium) nicht alle Parameter wie gewĂŒnscht konfigurieren. Ein Teil der Einstellungen kann ĂŒber die .htaccess-Datei vorgenommen werden, jedoch werden folgende Anpassungen nicht umgesetzt (die Werte in den Klammern sind die Werte, die HostEurope vorgibt):
opcache.enable_cli=1 (0)
opcache.interned_strings_buffer=8 (4)
opcache.max_accelerated_files=10000 (2000)
opcache.memory_consumption=128 (64)

Die Installation lÀuft unter PHP 7.0.

Ich habe bei HostEurope nachgefragt und folgende Antwort bekommen.

+++ Zitat Beginn +++
Sofern Sie mit den technischen EinschrĂ€nkungen und Alternativen nicht zufrieden sind, verbleibt Ihnen zum einen der Anbieterwechsel, oder die Nutzung eines selbst administrierten Systems. Wir verwalten weit ĂŒber 30000 Server und mĂŒssen dieses mit der vorhandenen KapazitĂ€t an Systemadministratoren durchfĂŒhren. HierfĂŒr ist es zwingend notwendig, entsprechend Standardpakete zu schnĂŒren. Anpassungen, ĂŒber die htaccess Datei hinaus sind nicht Update-Sicher und fĂŒhren zu erheblichen Mehraufwand.

Vielen Dank fĂŒr Ihr VerstĂ€ndnis.
+++ Zitat Ende +++

Ein selbst verwalteter Webserver ist aus mehreren GrĂŒnden nicht möglich.
Jetzt meine Fragen dazu:

Wie wichtig sind diese Einstellungen fĂŒr den Betrieb von Nextcloud?

Sind diese Einstellungen zwingend notwendig bzw. ist mit EinschrĂ€nkungen zu rechnen, wenn diese Vorgaben nicht (komplett) erfĂŒllt werden können?

Du kannst Nextcloud sogar ganz ohne OPCache nutzen, daher ist es nicht zwingend erforderlich. Dein Provider bietet es sogar an, jedoch mit etwas weniger Resourcen als empfohlen. Mit wenigen Nutzern gibt es vermutlich keine Probleme (das Problem wÀre vermutlich nur dass das Webinterface langsamer wird).

Wenn deine Nextcloud intensiver genutzt wirst, stĂ¶ĂŸt du frĂŒher oder spĂ€ter an die Grenzen von webhosting-Paketen und du musst ohnehin auf einen eigenen Server oder vServer umsteigen.

1 Like

Danke fĂŒr die Info :grinning:
Es sind 4-5 Benutzer und gelegentliche Nutzung (selten alle gleichzeitig) - dann sollte das Ganze ohne EinschrÀnkungen funktionieren :grinning:

@cloudman Bei Webhosting-Paketen sind oft der RAM und die Scriptlaufzeit sowie der fehlende SSH-Zugriff die limitierenden Faktoren.
Das ist natĂŒrlich von der App-Nutzung abhĂ€ngig.

Auch ich bekomme diese Fehlermeldung seit dem letzten Update auf 12.0.3. Ich habe im Gegensatz zu Cloudman den Server bei mir stehen und habe auch bereits in folgenden Dateien

/etc/php5/apache2/php.ini
/etc/php5/cli/php.ini

folgende Änderungen vorgenommen:

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

Jedoch bekomme ich immer wieder die Fehlermeldung:

Wer kann mir hier weiterhelfen?