Php limit does not work

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 16.0.4):
Operating system and version (eg, Ubuntu 18.04):
Apache or nginx version (eg, Nginx 1.16.1):
PHP version (eg, 7.2):

The issue you are facing:
Sorry for my English, I am writing through Google.
The problem with php file restriction. It costs 10 GB for maximum file upload. However, I can upload files larger than 10 GB via the WEB interface. Why it happens?
Thank.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

I assume Nextcloud upload a file in chunks and recompose the file when all parts have been transferred.

Thanks for the answer.
But then you can not change the default values of php. So I can leave 4 MB, and upload 100 GB through the web interface.
I understand correctly?
How then to limit the maximum load via the web interface?

Hello,

the upload limitation seems to be a mix of php-settings and nextcloud-settings.
See here: https://docs.nextcloud.com/server/16/admin_manual/configuration_files/big_file_upload_configuration.html
As far as i read the documentation, only sync-clients uses chunks to bypass upload limitations.

Hello!
I read this manual, but alas, I can’t understand anyway.
It turns out that these restrictions only work for sync clients. And for the web, anyway what are the limits?
Then the question is, if I put the parameter in client_max_body 10gb nginx and transfer the 72gb file through the client to Windows, then it is transmitted, but at the end it writes the error “timeout”, but still it is transferred eventually. Why it happens? Any thoughts?