PHP Fatal errors / Nextcloud timing out

Nextcloud version (eg, 20.0.5): 24.0.1.1
Operating system and version (eg, Ubuntu 20.04): Linux (unknown flavour)
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.53
PHP version (eg, 7.4): 5.6.40

I’m currently using a cheap shared hosting plan so have limited admin rights.

The issue you are facing:

Yesterday I successfully updated to Nextcloud 24, but shortly afterwards Nextcloud stopped working. It is failing to load/timing out via my browser so I am unable to access any pages. Sometimes I get a ‘500 Internal Server Error’ or a ‘503 Service Unavailable’ error. Occasionally a page will half-load but then be unresponsive. My desktop and mobile Nextcloud apps are unable to connect.

Because of this, I am unable to log in and access any settings.

Is this the first time you’ve seen this error?: Yes

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '####',
  'passwordsalt' => '####',
  'secret' => '####',
  'trusted_domains' => 
  array (
    0 => 'nextcloud.example.com',
    1 => 'www.nextcloud.example.com',
  ),
  'datadirectory' => '/home/username1/nextcloud.example.com/data',
  'dbtype' => 'mysql',
  'version' => '24.0.1.1',
  'overwrite.cli.url' => 'https://nextcloud.example.com',
  'installed' => true,
  'maintenance' => false,
  'dbname' => 'username1_nextcloud',
  'dbhost' => '127.0.0.1',
  'dbuser' => 'username1',
  'dbpassword' => 'pw',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'noreply',
  'mail_domain' => 'example.com',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'server123.webhost.com',
  'mail_smtpport' => '465',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpname' => 'noreply@example.com',
  'mail_smtppassword' => 'do-not-reply',
  'app_install_overwrite' => 
  array (
    0 => 'occweb',
  ),
  'theme' => '',
  'loglevel' => 2,
  'updater.release.channel' => 'stable',
  'updater.secret' => '####',
);

These are the three errors listed in error_log:

PHP Fatal error:  Uncaught Doctrine\DBAL\Exception: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[42000] [1203] User username1 already has more than 'max_user_connections' active connections in /home/username1/nextcloud.example.com/lib/private/DB/Connection.php:139

PHP Fatal error:  Uncaught Doctrine\DBAL\Exception: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[42000] [1203] User username1 already has more than 'max_user_connections' active connections in /home/username1/nextcloud.example.com/lib/private/DB/Connection.php:139

PHP Fatal error:  Uncaught Error: Class "OCA\DAV\Connector\Sabre\ExceptionLoggerPlugin" not found in /home/username1/nextcloud.example.com/remote.php:60

Thanks in advance for the help!

You hit the maximum number of database connections for this user.

That makes it probably difficult to change anything about, you can try and ask your hoster.

It was said that NC24 creates less load on the database, not sure if at some point this requires more connections…

What you can do?

Thanks for replying and the ideas – makes sense. I’ve reinstalled Nextcloud and have enabled APCu which will hopefully help. :+1: