PHP error in log

On my freshly installed NC, I have app. 10-15 files. I installed elasticsearch on a separate VM and run ./occ fulltextsearch:index only once. And there is no any cron job.

Still, I got this in log:
PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 24716184 bytes) in /config/www/nextcloud/apps/fulltextsearch_elasticsearch/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php on line 578

Could someone shed a light on this error? And how can correct it?


If you cannot assign more memory to the process, please try to lower the size of the chunk from the Full text search settings interface

I have plenty memory. I get this error in nextcloud docker. elasticsearch is installed in a separate VM.

Sorry for my dumbness, how can I assign more memory and also where, on the nextcloud docker or elasticsearch VM?


You should be able to do that by editing the php.ini file. I think the settings variable is ‘memory_limit’