Photos Synology

I have installed Nextcloud in Docker on my Synology. I would like to add my photos from my Synology to Nextcloud. For this I have already downloaded and installed the plugin external storage.
Unfortunately it does not work via web Dav. And smb is not installed. I have installed the latest Nextcloud version. Can you help me further?

Try mounting your syn-storage local in Nextcloud

Hey, yes I tried that too, the path is volume1/photo unfortunately no success.

Which errormessage is thrown by NC when trying to connect your storage locally?

Maybe you need to use absolute path.

Pls check manual for more into on how connecting correctly

That’s the funny thing, nothing is displayed in the log.
What do you mean with absolute path?

In your screenshot you use volume1/photo. Full path starts with a / e.g.

You can use cd on command line and go in the directory. Then execute:

basti@DS218:~$ cd /volume1/photo
basti@DS218:/volume1/photo$ pwd
basti@DS218:/volume1/photo$ cd
basti@DS218:~$ pwd

I think my mnt phat is /volume1/photo

Yes. But you must use /volume1/photo and not volume1/photo.
Also check user rights.

ls -la /volume1/photo
www-data:www-data (user:group) for the upper directory is needed.

You can check it:

sudo -u www-data touch /volume1/photo/testfile
Delete the file then.

Yes I also tried with /volume1/photo. Unfortunately it does not work either.
When I run the command:
ls -la /volume1/photo, then my folder list of photos appears and part is ‘users’ part is ‘SynologyPhotos’.
I just tried other paths. A red exclamation mark always appears in the external storage plugin.
At the command:

basti@DS218:/volume1/photo$ www-data:www-data user:users
-sh: www-data:www-data: Command not found

Please improve you linux knowledge. Your lines posted are not linux commands.
Please post
ls -al /volume1/photo
There is a directory “.” That is the directory itself. Who is owner and what is the group?

Respectfully, @devnull , telling someone “improve your Linux knowledge” isn’t always the most helpful.

OP, I am not too familiar with how the Synology product works, however you should be able to mount “/volume1/photos” as an external storage, just as you said. I am currently on my mobile phone and can’t read your attached screenshot very well. When I get back to my laptop, I’ll look a little further into your issue. Don’t be too frustrated; I’m sure our collective brains will figure it out.

Be well,


It works now. I use webdav.


Yes. WebDAV is a solution. But if the data is theoretically accessible locally, local would certainly be the better solution e.g. for performance and stability.


Sorry for my words. But this makes really no sense.
www-data:www-data is no command.