# Permission denied

**URL:** <https://help.nextcloud.com/t/permission-denied/12669>\
**Category:** 📄 Office\
**Tags:** collabora-online\
**Created:** [May 16, 2017, 1:31pm UTC](https://help.nextcloud.com/t/permission-denied/12669 "2017-05-16T13:31:43Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![myshevchuk](https://help.nextcloud.com/user_avatar/help.nextcloud.com/myshevchuk/32/5776_2.png) [@myshevchuk](https://help.nextcloud.com/u/myshevchuk)\
**Post date:** [May 16, 2017, 11:46pm UTC](https://help.nextcloud.com/t/permission-denied/12669/2 "2017-05-16T23:46:59Z")

</div>

I found docker constantly restarting was related to mismatching kernel and docker versions.

In my case it was _debian kernel 3.16.0-4-amd64_ from debian stable and _docker 17.03.0~ce-0~debian-jessie_ from docker-ce stable. Upgrading to _4.9.0-0.bpo.2-amd64 (debian 4.9.18-1~bpo8+1)_ made things even worse: the docker service wouldn’t start at all. Fixed by purging docker-ce (including /var/lib/docker, it was a fresh installation anyway) and installing (appeared to be downgrading) _[docker.io](http://docker.io) version 1.6.2_ from debian stable backports.

Perhaps with some trial and error you could fix your problem as well.

My installation:

- **uname -a:**  
Linux [mydomain.com](http://mydomain.com) 4.9.0-0.bpo.2-amd64 #1 SMP Debian 4.9.18-1~bpo8+1 (2017-04-10) x86\_64 GNU/Linux
- **docker --version**  
Docker version 1.6.2, build 7c8fca2
- **nextcloud**  
11.0.3 (production)
- **openssl version**  
OpenSSL 1.0.2k 26 Jan 2017
- **nginx -v**  
nginx version: nginx/1.10.3 (from [dotdeb.org](http://dotdeb.org) repositories)
- **apache2 -v**  
Server version: Apache/2.4.10 (Debian)
- **php --version**  
PHP 7.0.19-1~dotdeb+8.1 (cli) ( NTS ) (from [dotdeb.org](http://dotdeb.org) repositories)
- **mysql --version**  
mysql Ver 15.1 Distrib 10.0.30-MariaDB, for debian-linux-gnu (x86\_64) using readline 5.2

In my installation, Nginx is used as a reverse proxy for both Nextcloud (https:// [cloud.mydomain.com](http://cloud.mydomain.com) =\> apache2 localhost:8080) and Collabora suite (https:// [office.mydomain.com](http://office.mydomain.com) =\> docker localhost:9980).

Collabora and Nginx were configured as described here: [https://nextcloud.com/collaboraonline/](https://nextcloud.com/collaboraonline/) (step 1 and step 3) and here: [https://icewind.nl/entry/collabora-online/](https://icewind.nl/entry/collabora-online/) (step 2).

---

_[View the full topic](https://help.nextcloud.com/t/permission-denied/12669)._
