Permission Denied for Android Uploads

I have googled for hours now and i can get the uploads to work from Android App. Windows App is fine etc. Folder Permissions tested at 777. (You do not have permissions to upload to this folder) and Permission error username@site

Hi @Matthew_Walsh,

what do you see in the log files on your server (and also on your Android client in case you are running the beta version)?

I think this is the log your after.

{“reqId”:“3dc48KMrx6HKc5uT3nRK”,“remoteAddr”:“”,“app”:“core”,“message”:“Login failed: ‘username’ (Remote IP: ‘’)”,“level”:2,“time”:“2016-11-14T22:35:48+00:00”,“method”:“PROPFIND”,“url”:"/remote.php/webdav/",“user”:"–"}

{“reqId”:“5Vw5s3Rlth1VBVDjllhy”,“remoteAddr”:“”,“app”:“PHP”,“message”:“Undefined index: MemAvailable at /home/link/link/apps/serverinfo/lib/SystemStatistics.php#85”,“level”:3,“time”:“2016-11-15T01:44:18+00:00”,“method”:“GET”,“url”:"/index.php/apps/serverinfo/update",“user”:“USERNAME”}

No Beta. Custom ROM on phone. No other issues.
cPanel Version 60.0 (build 24)
Apache Version 2.2.31
PHP Version 5.6.24
MySQL Version 5.6.33-cll-lve
Architecture x86_64
Operating System linux

Can you disable the serverinfo app? If it solves the error, please report it to the serverinfo-app.

I still can not upload unfortunately :frowning:
Thanks for trying

Still the same error?

Yeah from uploading on phone. Permission error. I even troed 777 on
folders. So odd

I moved to the android section. @Andy does this error help you or do you need more information (e.g. version numbers)?

We would also need

  • the version number of the app and if possible a test account (can and should be send via PM to me and @tobiasKaminsky) where this can be reproduced.
  • Manual upload or instant upload?
  • any folder or a specific one?

Apears to be working now :slight_smile:

1 Like

How could this answer be marked as a solution?

Appears to be working

Ok, I have the same issue, what kind of magic I might apply to my installation?

UPD: in my case I had an issue in the nginx config: I added deny all rule for all . - dot-files

As a result, when my android NC application tried to copy/move/upload/sync files it tried to access xxxx/xxx/.file path which was restricted by nginx, and the app always get 404 from the server for every request. So I get “You do not have permission to upload in this folder” error in the android application. Though, the desktop application didn’t have any problems.

Solution: update the nginx-config (in my case - make deny all more granular, at least - allow access to .file paths)

Still no definite solution.
Exactly the same symptoms, everything works except Android app. It logs in, lists contents, can create folders, delete folders and files, but cannot create (upload) any file - “You do not have permissions to upload to this folder”.

Something is wrong in Android app, because Web interface and the desktop app work fine.

I think it might be interesting to know that ownCloud Android app fails exactly the same way on this hosting, though everything else works (in a separate datastore, of course).