Ownnote - no display of notes in 11.0.1

Hi,
I am trying to use ownnote with 11.0.1 but the text of the notes is not displayed.
Cannot find anything in the logfiles.
Anyone with an idea how to solve this?

Thank you,
Martin

Interesting, I also use it and doesn’t face any problems. I guess you adjusted the info.xml, otherwise it should not be possible to enable the app?

I changed behaviour to use database AND folder for the note storage. Maybe you try that also, since the app is not maintained for a while there appeared several problems: https://github.com/Fmstrat/ownnote/issues

Did you check your browser console for errors?

I’m facing the same issue, the edit page is just blank (no edit toolbar, no text field).
I already had the setting to use database and folder and if I create a new note it also creates a new file (but I can’t edit it).

Yes, I modified info.xml.
Console error shows this for probably all of the .js files - any idea how to solve this?:

Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf https://abc.def.com/oc/apps/ownnote/js/tinymce/themes/modern/theme.min.js blockiert (“script-src ‘nonce-UzlmY3VPbE9xTDhhcHM1UEowMFo1Ym1rLyttVzZkTk56MVMxSXJaalc1cz06RDUrbGlhb3ZtTXRpL0tzVmJEUmZ6dkgyejV6M3VJTVl1Z0gzVit3S0U5Yz0=’ ‘unsafe-eval’”).

btw, how do you change the behavior you mentioned regarding the usage of database AND folder?

Hmm, some secrity issue. This nonce value is used to varify that the website stays communicating with the same client or something. No idea how this could fail there, if other nextcloud works fine. The error message has high chance to be connected to your issue as it occurs on some theme file.

I would try to remove the app and reinstall it cleanly from github.

The setting you requested is set in admin panel/other settings, the place where all 3rd party apps place their settings.

1 Like

@MichaIng: Thank you! I removed and reinstalled - the result is that I do not get the nonce value error message anymore but apart from that nothing changed.
But I guess I got a little step closer to the solution. I now see these messages:

“Failed to load: https://abc.def.com/oc/apps/ownnote/js/tinymce/themes/modern/theme.min.js
“Failed to load: https://abc.def.com/oc/apps/ownnote/js/tinymce/plugins/advlist/plugin.min.js
“Failed to load: https://abc.def.com/oc/apps/ownnote/js/tinymce/plugins/autolink/plugin.min.js
… (full list is 19 lines)

The files exist and the permissions also seem to be ok (755).

Hmm, @bakfietz and others also faced some problem about the nonce and reported on github: https://github.com/Fmstrat/ownnote/issues/333

I am not sure if this is really the same issue, because you were able to at least fix the nonce messages by just reinstall the app, where the others needed to disable some security check in firefox or apply the workaround given there. In Chrome on the other hand clearing browser cache fixed the issue, did I understand this right @bakfietz?

The browser console does not provide some more details, just “Failed to load”? Did you check nextcloud and webserver logs again?
Also try to chown -R the app directory to your http user, just in case…

Ok, solved. The workaround at https://github.com/Fmstrat/ownnote/issues/333

Open firefox,
enter about:config.
Then set security.csp.enabled to false.

fixed it for FF.
Thanks a lot!