Owncloud migration fails postgres

Hi all,

I’m trying to migrate from my existing owncloud 10.0.3 installation to Nextcloud 12.0.4.
As database I’m using postgresql 9.6.6

When I run the upgrade via occ, this is the result:

2017-12-05T19:39:21+00:00 Set log level to debug
2017-12-05T19:39:21+00:00 Repair step: Repair MySQL collation
2017-12-05T19:39:21+00:00 Repair info: Not a mysql database -> nothing to do
2017-12-05T19:39:21+00:00 Repair step: Repair SQLite autoincrement
2017-12-05T19:39:21+00:00 Repair step: Copy data from accounts table when migrating from ownCloud      
2017-12-05T19:39:21+00:00 Repair step: Drop account terms table when migrating from ownCloud
2017-12-05T19:39:21+00:00 Updating database schema
2017-12-05T19:39:22+00:00 Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'ALTER TABLE oc_filecache ALTER fileid TYPE SERIAL':

SQLSTATE[42704]: Undefined object: 7 ERROR:  type "serial" does not exist
2017-12-05T19:39:22+00:00 Update failed
2017-12-05T19:39:22+00:00 Maintenance mode is kept active
2017-12-05T19:39:22+00:00 Reset log level

Did anyone successfully perform a migration like this? Is there any workaround available? I only found a suggestion to use a “–skip-migration-check” commandline switch - though that doesn’t seem to be implemented anymore.

Thanks in advance

1 Like

I think you can post this directly on the bug tracker https://github.com/nextcloud/server/issues

Okay, is now an issue on github:

Thanks for the feedback.

I have wasted my sunday with trying to migrate from owncloud :frowning_face:

Is there now a way with postgres? The updater tries to update to 12 …
The bug is fixed in 13?

The bug is closed and was on the timeline for NC13, so it should be fixed in NC 13.

1 Like

OK. An is there now a way from my OC to the NC 13 ?

For OC 10.0.3, it should work: https://nextcloud.com/migration/
I’m not sure if the migration app directly migrates to NC 13 or does a migration to NC 12 first.

The migration to NC 12 is impossible with the postgres bug :frowning:
Therefore I ask so direct …

same problem for me today … I tried a migration from OC-10.0.4 to NC-12.0.4, and I am experiencing the same error.

ERROR:  type "serial" does not exist

this problem concerns postgresql 9.4 and 9.6…

With postgresql-10, postgresql-11, postgresql-12 and postgresql-13 the error is as follows:

Undefined column: 7 ERROR: column "min_value" does not exist in oc_account_terms_id_seq

any help would be appreciated

Thanks in advance