Owncloud desktop client broken in use with nextcloud

I am opening a new thread in a follow up to this conversation Problems installing @ webhoster , because after everything else seems to be working one problem remains consinstent:

the mac os x client for own cloud does (in my case) not work with nextcloud.

did a fresh install on the hosted webspace of nextcloud, no beta version, latest stable version of 9xxx.

we repaired all the rights, installed a tmp directory. error messages now appearing are minor and have also been appearing with owncloud.

when i use this very domain with owncloud, the desktop client will log in the account and start transfer.

when i use this domain with nextcoud, i will always always get an error message that the server doesnt allow access. (see image)

When i follow the link to login with the same passwort / username via webbrowser, i will log into nextcloud with no problems.

also, no error is visible in the log from the login attempt.

Do your logs tell you anything?

Don´t think so, as I tried to point out, there does not seem to be ANY log entry which is related to the trial to log via the desktop client.

ooops, update: no entries when logging for “errors”, but changing to “log all things”, i got the following message:

Exception: {“Message”:“HTTP/1.1 401 No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is mis-configured”,“Exception”:“Sabre\DAV\Exception\NotAuthenticated”,“Code”:0,“Trace”:"#0 [internal function]: Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#1 /kunden/XXXXX/kumo/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#2 /kunden/XXXX/kumo/3rdparty/sabre/dav/lib/DAV/Server.php(446): Sabre\Event\EventEmitter->emit(‘beforeMethod’, Array)\n#3 /kunden/XXXX/kumo/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 /kunden/XXXX/kumo/apps/dav/appinfo/v1/webdav.php(55): Sabre\DAV\Server->exec()\n#5 /kunden/XXXX/kumo/remote.php(138): require_once(’/kunden/XXX…’)\n#6 {main}",“File”:"/kunden/XXXX/kumo/3rdparty/sabre/dav/lib/DAV/Auth/Plugin.php",“Line”:188,“User”:false}

Also, I will get an error saying some files didnt pass integrity check:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • .htaccess
    • FILE_MISSING
      • .user.ini
  • files_external
    • INVALID_HASH
      • l10n/nl.js

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[.htaccess] => Array
(
[expected] => 4a97aae4d05df89a28bf2e63fe2a31cdf2afe74d3c9f622afb581d6b0f1f4e001639c7c3a31d7aaa793c00d5f355e0bfaad62ec45507245de441cfc552115cd7
[current] => cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
)

            )

        [FILE_MISSING] => Array
            (
                [.user.ini] => Array
                    (
                        [expected] => 0a557e3cdca4c2e3675deed761d79d109011dcdebbd9c7f6429f1d3476938ec95729543d7384651d1d0c48e26c5024cc5f517445920915a704ea748bdb903c5f
                        [current] => 
                    )

            )

    )

[files_external] => Array
    (
        [INVALID_HASH] => Array
            (
                [l10n/nl.js] => Array
                    (
                        [expected] => f4a814c9012a1a87693731d2cef19547c55806d9023ca4d85e000d063ee584f7bc65e603c472f8cb4311921e1f4cc486e606c3c3206a30b3c7db48aedf94567f
                        [current] => ff74dd8c70ab220a7cda323a27ffddcb018b777a6200943828a2370fa70dce4911609067a3bdeb0ed86f228c7cd99bf18770f79382f7fc6fd2539f0aec54dec8
                    )

            )

    )

)

Webhosters Support wrote me that there are some files missing, where the system wants to write to user.ini, which doesnt seem to exist:

Wir können Ihnen bestätigen, dass es serverseitig kein Problem diesbezüglich besteht. Wie bereits mitgeteilt, haben wir die in dem Forum beschriebene Direktive mod_rewrite in der .htaccess eingefügt haben. Die eigentliche Fehlermeldung sagt aus, dass Owncloud das Upload Limit in /kunden/XXX/kumo/tmp/oc_tmp_Ur5hjg-folder/.user.ini schreiben will. Die Datei existiert nicht.

Die folgendene Fehlermeldung besagt, dass die Datei /kunden/XXXXX/kumo/.user.ini in der /kunden/163850_80799/kumo/lib/private/integritycheck/checker.php aufgerufen wird:

Error PHP copy(/kunden/163850_80799/kumo/.user.ini): failed to open stream: No such file or directory at /kunden/XXXX/kumo/lib/private/integritycheck/checker.php#189

Diese .user.ini Datei existiert auch nicht.

Please check the configuration of your apache or nginx installation. I had the same error a few months back when it was still just owncloud and solved it by checking my nginx configuration against the documentation. I do not know what changed in the requirements.

This link might help you though:

In short, check the rewrite rule if you are using Apache. Or similar configuration settings for nginx.
The link says something about self signed certificates, and OS X I had it on Ubuntu 16.04 with Lets Encrypt certificates, but I am fairly certain that will give you the needed hint. If you are running Apache, check your .htaccess

I hope that helped.

1 Like

Finally!!! I am able to log in, thanks…

.htaccess now looks like this:

DO NOT CHANGE ANYTHING ABOVE THIS LINE

RewriteEngine On
RewriteBase /
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
ErrorDocument 403 //core/templates/403.php
ErrorDocument 404 //core/templates/404.php

Header always set Strict-Transport-Security “max-age=15552000; includeSubDomains; preload”

Strangely enough, i will still get an alert “https is not configured correclty, set htts… etc”

But just to keep going in the right direction: when I log in now, I will see another error message in the logs - should I do anything about this?

Exception: {“Message”:“HTTP/1.1 401 No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is mis-configured”,“Exception”:“Sabre\DAV\Exception\NotAuthenticated”,“Code”:0,“Trace”:"#0 [internal function]: Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#1 /kunden/XXXX/kumo/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#2 /kunden/XXXX/kumo/3rdparty/sabre/dav/lib/DAV/Server.php(446): Sabre\Event\EventEmitter->emit(‘beforeMethod’, Array)\n#3 /kunden/XXX/kumo/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 /kunden/XXXXX/kumo/apps/dav/appinfo/v1/webdav.php(55): Sabre\DAV\Server->exec()\n#5 /kunden/XXXX/kumo/remote.php(138): require_once(’/kunden/XXX…’)\n#6 {main}",“File”:"/kunden/XXX/kumo/3rdparty/sabre/dav/lib/DAV/Auth/Plugin.php",“Line”:188,“User”:false}

Please see this thread for DAV configuration, and your error message:

as well as the Server Configuration for nextcloud with apache:
https://docs.nextcloud.com/server/9/admin_manual/installation/source_installation.html#apache-configuration-label

Also this general tutorial on how to configure it for apache:
http://books.gigatux.nl/mirror/linuxtroubleshooting/9149final/LiB0153.html

I have asked support from my webhoster about this and they actually tell me its a known bug in owncloud/nextcloud and the error message doesnt really pose any problem, can be switched off - correct?

(sorry don’t have more time to read the details), you’ve probably tried the following tips of the old FAQ:
https://forum.owncloud.org/viewtopic.php?f=17&t=30646