Ordner konnte nicht geöffnet werden

Liebe Nutzer des deutschen Subforums.

Es passiert leider häufig genug, dass ganz wesentliche Infos bei vielen Threads fehlen. Dabei weiß niemand außer Euch selbst, wie ihr eure Maschine(n) konfiguriert habt. Doch Informationen sind wesentlich für eventuelle Helfer.

Bitte beachtet beim Posten deshalb folgende kleine Hinweise - die erleichtern allen die Fehlersuche. Und sparen allen Zeit. Und auch Nerven :wink:

  • Bei welchen Anbieter? Was für ein Server? v-server, shared, root, usw. Oder Lokal?
  • Auf welcher Hardware? | Raspberry PI
  • Betriebssystem sowie Version ALLER beteiligten Systeme | Neuste RPi_5 Version
  • Nextcloud Version: Nextcloud Hub 25 Autumn (32.0.8)
  • PHP Version: PHP 8.4.20
  • Welche Datenbank? MariaDB
  • Apache version, Apache/2.4.66 (Debian)
  • Läuft NC in Docker,Snap oder VM | rein auf der RPi_5
  • Netzwerk Aufgliederung: zb. Router >PI>
  • Wurden vor kurzen Server Updates gemacht? Wenn ja von was? | NEIN
  • Habt ihr die Logs angesehen von Nextcloud und von System? | Zeigt kein Fehler an
  • Bei was für einer Aktion ist der Fehler aufgetreten?
    • Ich habe versucht meine Gmail in meine Nextcloud einzupflegen. Das anmelden hat super funktioniert aber mit wird angezeigt wenn ich auf einen Ordner clicke “Ordner konnte nicht geöffnet werden”.
    • Ich habe schon einiges ausprobiert (Neues App Passwort, Konto entfernt und neu hinzugefügt)

Hallo zusammen,

ich hänge mich hier mal mit dran, da ich ein sehr ähnliches Problem mit der Nextcloud Mail-App habe.

Bei mir läuft Nextcloud auf einem Webspace bei Dogado, also kein eigener Root- oder vServer. Aktuell nutze ich Nextcloud 33.0.3.2 mit PHP 8.4-FPM. Die Mail-App lässt sich grundsätzlich einrichten, IMAP/SMTP funktionieren auch soweit.

Das Fehlerbild ist bei mir etwas spezieller:

Unterordner lassen sich öffnen und die E-Mails darin werden angezeigt. Nur der Posteingang ließ sich nicht öffnen, dort kam ebenfalls die Meldung:

„Ordner konnte nicht geöffnet werden"

Ich habe dann testweise den Posteingang in Thunderbird aufgeräumt und die verbliebenen Mails in einen temporären Ordner verschoben. Der Posteingang funktionierte danach wieder.
Der temporäre Ordner mit den verschobenen Mails ließ sich dafür nicht mehr öffnen.

Damit war relativ klar, der Fehler wandert mit bestimmten Mails mit. Es liegt also offenbar nicht am Ordner selbst, sondern an einer oder mehreren problematischen E-Mails.

Im Nextcloud-Log habe ich dazu unter anderem diesen Fehler gefunden:

Allowed memory size of 1073741824 bytes exhausted

Der Fehler trat im Zusammenhang mit der Mail-App auf, konkret beim Öffnen/Verarbeiten des Ordners bzw. der Nachrichten. Aus meiner Sicht sieht das danach aus, dass die Mail-App bei bestimmten Nachrichten, vermutlich wegen Zeichensatz/MIME/HTML/Anhang oder ähnlichem, beim Verarbeiten in den Speicher läuft.

Ich habe die betroffenen Mails dann stückweise eingegrenzt. Das funktioniert zwar grundsätzlich, ist aber natürlich keine Dauerlösung. Ich kann ja schlecht jedes Mal Mail-Forensik spielen, sobald jemand eine kreative E-Mail aus der Hölle verschickt. Thunderbird und andere Clients kommen mit denselben Mails übrigens klar.

Cache leeren, Mailkonto entfernen und neu einrichten hat bei mir nichts gebracht. Das Problem kommt wieder, sobald die problematische Mail in einem Ordner liegt, der von Nextcloud Mail geöffnet wird.

Kurz gesagt scheint „Ordner konnte nicht geöffnet werden" nicht zwingend ein IMAP- oder Loginproblem zu sein, sondern kann auch durch einzelne problematische E-Mails ausgelöst werden, bei denen die Mail-App beim Verarbeiten abstürzt bzw. das PHP-Memory-Limit erreicht.

Vielleicht hilft das bei der Eingrenzung. Falls jemand eine saubere Lösung kennt, z. B. bestimmte Mail-App-Version, Einstellung, Workaround oder bekannte Ursache bei MIME/Charset-Verarbeitung, wäre ich dankbar.

Viele Grüße
Carsten