OpenStack V2 not working in NC14

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 14.0.1
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04.1
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.34
PHP version (eg, 7.1): 7.2.10

The issue you are facing:

I’ve configured an OpenStack Swift V2 endpoint (my host doesn’t support V3) but no matter what I try, I never get the green tick in the settings.

Nothing appears to be logged. Strange thing is, the exact same settings work fine in ownCloud.

Here’s the documentation for my hosts service: https://www.memset.com/docs/other-memset-services/memstore/developers/

I’m setting the auth URL in NC to the “Auth 2.0 (keystone)” URL.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Enable the external storage app
  2. Configure a new storage with OpenStack V2 with the correct details (service name = memstore, region = reading, bucket, user, password, tenant, auth URL)
  3. Click the tick

The output of your Nextcloud log in Admin > Logging:

Nothing logged, only errors are related to my IMAP account

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

php
$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'xxx',
  ),
  'datadirectory' => '/data/nextcloud',
  'dbtype' => 'mysql',
  'version' => '14.0.1.1',
  'overwrite.cli.url' => 'xxx',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'updater.release.channel' => 'stable',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'localhost',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpport' => '25',
  'mail_from_address' => 'xxx',
  'mail_domain' => 'xxx',
);

The output of your Apache/nginx/system log in /var/log/____:

[Tue Sep 25 23:48:52.464683 2018] [mpm_event:notice] [pid 14895:tid 140094086884288] AH00489: Apache/2.4.34 (Ubuntu) OpenSSL/1.1.0h configured -- resuming normal operations
[Tue Sep 25 23:48:52.464716 2018] [core:notice] [pid 14895:tid 140094086884288] AH00094: Command line: '/usr/sbin/apache2'