Open docs in OnlyOffice instead of Collabora

Ubuntu server w/ snapd
Snap Nextcloud --edge
Hosting out of LAN through ngrok.

I had previously tried Collabora office but it wasn’t working, so I disabled and then removed it.
Next, I installed the Community Document Server and ONLYOFFICE apps.
Now when I create a new .docx document, it opens up right into OnlyOffice, but if I close it and try to reopen, it tries to open with Collabora (which was already uninstalled, hence nothing happens).

Any idea how to fix this and have my NC open documents with OnlyOffice by default?

have you disabled the collabora app? or do you still need both?

I disabled and removed Collabora before I installed the Comminty Document server and OnlyOffice

Maybe there’s a problem with the mime types or something. You could always try to make your own mime type configuration according to this page
You could also check the database if there are a bunch of collabora stuff still there and maybe drop those tables. but make sure to backup the db first, and honestly this last idea is probably not helpful at all… but I’ll leave it anyway for some reason.

Thanks Luvis.
That was too advanced for me, but it got me to play around with the settings menu and in the OnlyOffice tab I unchecked opening certain document types with OnlyOffice → Save settings → re-check → Save settings.
It worked and now I can open docs with OnlyOffice.
Perhaps it just needed a little push to make sure those were the default settings for documents.

Seems like you found the best solution =) Glad you figured it out!