OO <-> NC integration. Chrome works but firefox does not


so i have OO and NC on the same host. NC is running on port 80 and OO is installed on docker. There’s a nginx server doing https reverse proxy for OO.

Everything works on chrome.

So… i tried to edit a file on firefox and the “ONLYOFFICE cannot be reached. Please contact admin” appears.
I tried to debug with the developer console/logs/wireshark but i couldn’t find out what’s happening.
nginx (which is supposed to serve OO) doesn’t even receive requests so it might be a browser control. but the firefox console doesn’t give anything.

Does anyone have any clue where to start looking at?


I had many issues in the past where I was wondering why it doesn’t work although it should and it came down to Firefox many times. What I noticed was, that Firefox does a lot of caching and rather provide cached files then contacting the server.
You could try to delete the cache under "Settings -> Extended (? Erweitert in German) -> Network"
Here you can hit “Clear now” under “Cached web content”.

Unfortunately that was not the case

Can you check with one more browser? If you use Windows 10 a test with Edge would be perfect.
Apart from that, do you use any Add-Ons in Firefox that might interfere? Disabling all Add-Ons to see if there is a difference could be worth it.
Furthermore, which version of Firefox do you use? Which version of Chrome?

With https://www.ssllabs.com/ssltest/ you could check the compatibility of your website and which browser(s) (versions) should work.

Did you change any values in

Especially changed values for SSL parameters could be interesting:

(just an example)

i’ve just tried with IE (win 8.1) and again it doesn’t work.
No particular addons on firefox.

Chrome is 60.0.3112.90
firefox ESR 52.2.1

In about:config everything regarding ssl is set at default.

I tried the ssltest site but it doesn’t accept IP addresses

This is weird. Is your server publicly available or only in your LAN?
Can you access the onlyoffice website directly?

Could you post the nginx- configs and the command you started the OO docker with?

If you mounted the Onlyoffice data directory (with the log files and so on) to a directory, you could also check the OO log files for errors and problems.
Apart from that - depending on the OS and system daemon you use - do the logs (i.e. journalctl) tell you something?
Or maybe do it the hard way:
try to open an office file with OO and right away execute:
find / -name *.log -print0 | xargs -0 ls -ltr
to find the latest logs; hoping that we find some helpful error messages that way.