ONLYOFFICE not working on fresh install - curl error


The onlyoffice integration on a fresh 18.0.3 installation does not seem to work.
When I click on “save” in the ONLYOFFICE settings (to trigger the HealthcheckRequest), I get the following error:

 HealthcheckRequest on check error: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see

My setup is the following:

I have tried the following:

  • Using to check if there was a problem in my certificate chain (there is not)
  • Uninstalling/reinstalling the integrator and the server app (in all possible orders), rebooting
  • Erasing settings in the “ONLYOFFICE” tab, filling them in again
  • disabling ssl check in php config, that gives me a wrong gateway problem, probably because all traffic is redirected to https. (would’nt be a real solution anyway, I want a secure installation)

Does someone have any ideas as to what I could do to troubleshoot the problem further?
With the whole “It just works” thing, documentation as to where config files are etc. is sparse.

Thanks for your help!

You need to install the cert :


Thanks for your help!
I tried to install the CA’s in three possible ways (package manager, manually, import into nextcloud via occ command) but it didn’t work.

I found the answer though!
I had to create an entry in my dns server that redirected the url to the local IP address.

Now it works fine