"ONLYOFFICE est indisponible. Veuillez contacter votre administrateur✖" (SOLVED)

Greetings,
It seems that a lot of chum have the same trouble that I have but I can’t find an answer to it.
The context :
Nextcloud20.0.6 installed in a synology ds220+ not in docker but with the community app.
I cant use everything except onlyoffice (who is installed via the nextcloud store and seem to be correctly set) I have the option to create documents and it tells me that the doc is created and I can find it but there is still a dreaded "“ONLYOFFICE est indisponible. Veuillez contacter votre administrateur”
So, if anyone has an idea, I will be happy to try anything :slight_smile: (except murder of course)

Hi @John_CUENI , Have you try to uninstall and install the community app ?
Have you some logs on this issue ?

Hi @Mageunic, thanks for your help,
I think so, if the name is “ONLY OFFICE Connector”, yes other than that … no.
I can’t find an app with that name either.
What do you mean by “logs on issues” ?
Have a nice day.

@John_CUENI which method you use to have an onlyoffice server?

Community Document Server:
https://apps.nextcloud.com/apps/documentserver_community

Onlyoffice Doc:
https://helpcenter.onlyoffice.com/installation/docs-index.aspx

or docker of onlyoffice doc

The onlyoffice app is just a connector to the onlyoffice server

Thank you, I will look into this.
As I read the description, it says “ONLYOFFICE connector allows you to view, edit and collaborate on text documents, spreadsheets and presentations within Nextcloud using ONLYOFFICE Docs”
So does that mean I need three things : the server, docs and connector ?
I am confused …
I have checked :slight_smile:
“sudo -u http php74 /volume1/web/nextcloud/occ app:install onlyoffice”
Gives me
onlyoffice already installed
More confused I am now …

I followed : How to install ONLYOFFICE in Nextcloud Hub – Nextcloud
It is pretty straight forward, but so far no chance …

@John_CUENI to use onlyoffice you need only a server and onlyoffice app ( connector)
to install the server you have some choice the app:

Community Document Server:
https://apps.nextcloud.com/apps/documentserver_community

or

Onlyoffice Doc:
https://helpcenter.onlyoffice.com/installation/docs-index.aspx

( there is some docker for onlyoffice if you want to use a docker install)

after installing the server you can install the onlyoffice apps ( https://apps.nextcloud.com/apps/onlyoffice)

If you have installed Community Document Server app you don’t need to configure onlyoffice app normally.

If you have installed Onlyoffice Doc, you need to set the domain name to access to your onlyoffice server and set local ip in advanced setup.
If your server is on the same network than nextcloud,
you have to add this line into your config.php :
‘allow_local_remote_servers’ => true,

just ignore the number after “:”

Screenshot Fehlermeldung

Hi,
getting the attached error when opening an onlyoffice document (fails). Connection to the community server seems to be ok according to occ test. Nextcloud 20.0.6 installed in docker container behind traefik reverse proxy.

My own fault. The above described entries in config. phb solved my problem, too (just messed it up on frist try):

‘overwrite.cli.url’ => ‘https://myserver…’,
‘overwriteprotocol’ => ‘https’,

Sorry for the confusion.

Hi @Mageunic,
Thank you for your help, it is appreciated !!
Unfortunately,

Citation ‘allow_local_remote_servers’ => true,

Is already set, I’ve tried with the localhost adress like your screen capture but it doesn’t work, the only way to not have an error is to set the same value to the “document editing service address”, and the two others.
So far I have now a blank page for few seconds and then a black “contact your administrator”

Hi @John_CUENI,
Have you set correctly the port of your onlyoffice server and nextcloud inside the IP you set in advanced server settings?
On my side, the nextcloud server is set on port 80 ( no need to specify the port on IP address) and my onlyoffice server is set on port 8082.

Well, how do I check which port is used ?
I use the name of the server instead of the ip address and I have unsuccessfully tried 80, 8000, 8080, 8081, 8082 and 8083 as ports …

@John_CUENI which installation (docker,Onlyoffice Doc directly on your server ?, Community Document Server app) you use for onlyoffice server?

I’ve installed it within nextcloud app

the comunity one.
The installation is not in docker, I’ve done it manually in my DS220+

@John_CUENI
you don’t need to configure the application normally.
See section Configuring OnlyOffice: GitHub - nextcloud/documentserver_community: Document server for onlyoffice

That was what I read … everything works right out of the box … apparently.
Guess what, it is not working … :sob:

@Mageunic, thank you for your help, I will sleep on it and try to find what’s what tomorrow !

… still not working, I’ve tried via docker and “The portal start up process might take some time, please wait…” but wait 1 hour and still not starting …
:tired_face: :weary:

@Mageunic do you know where I can find the logs that will track this problem ?

@John_CUENI maybe in the nginx log or something like that. I have only use default installation ( not docker or Community Document Server app)
Can you have access to the web page of onlyoffice using a port configured?