ONLYOFFICE docker not reachable from Workplace WAN but from LAN

Hi folks,

i installed under Nextcloud the Onlyoffice connector App.
I followed this instruction to build a working docker community document server reachable under port 8443

I have installed ufw and remarked problems after upgrade to ONLYOFFICE 7.1.0 so made some investigations and found this information

cURL error 35: OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to · Issue #280 · nextcloud/contacts · GitHub

i set ufw allow from any to <>
from that beyond saving the ONLYOFFICE settings worked again.

Now my test form LAN, everything ok, creating new docs / changing existing docs all good.

From my Work i tested as well and get “ONLYOFFICE temporarily not available, please contact Administrator”

Testing https://MY-NEXTCLOUD-FQDN:8443 delivers “blocked” (Connection refused)

I have to mention, that for the moment i opened the portforwarding 8443 → to local IP:8443 of my nextcloud server directly because i can’t get it working with my existing reverse proxy.

I tested the same address from mobile device with SIM card → working, port 8443 is reachable.
At work port 8443 is blocked.

My Nextcloud is behind a reverse proxy that support delivering my nextcloud instance under port 443. This standard https port isn’t blocked by Workplace IT. So nextcloud is reachable.

I can’t run docker image under port 443 as well because already in use by nextcloud.

So which reverse proxy settings do i need (nginx server) to deliver traffic from 443 to ONLYOFFICE docker?

And second question how can i get it working as long the url in the nextcloud app ONLYOFFICE settings is named https://MY-NEXTCLOUD-FQDN:8443 ?
(https://MY-NEXTCLOUD-FQDN:443 is not possible because same address as nextcloud server itself)

ok got it working after several hours of investigations and some liters of wine …

had to optain / issue a new sub-domain for openoffice by and made a new oo.conf file on my reverse proxy for pointing ssl 443 to 8443 on my cloud machine that also is runing my docker container under 8443:443 re-pointing to 443.

Under admin → settings → ONLYOFFICE i set my public url to https://openoffice.server.url
and local url to https://openoffice.server.url:8443

The instruction for doing all steps is here

glad to have access to my openoffice docs from working place either now.

And more important, i can close the portforwarding 8443 in router config.