ONLYOFFICE Desktop Editors now connectable to Nextcloud


#1

The latest version of ONLYOFFICE Desktop Editors can be connected to Nextcloud file system to work on documents from the desktop environment.

Read the details in our blog or download the new version right away.

Mind that ONLYOFFICE Document Server is still required!


#2

Awesome news! Was really looking forward to that.
Edit: Snap packages not yet ready though it seems…


#3

Hi!

The snap is in progress, you will have it soon too. I’ll drop a link here :slight_smile:


#4

I tested it with the .deb on another system. Works great, however it doesn’t seem to remember the connections like previously with the OO community server?


#5

Hi!

What exactly do you mean by remembering connections?

BTW, the snap is already here: https://snapcraft.io/onlyoffice-desktopeditors


#6

If you enter a new nextcloud connection it opens a new tab with the Nextcloud interface. But if you close that tab you need to enter again the URL etc. to reconnect. Previously you could store a connection and would just have to reenter the password to connect.

Thanks for the Snap!


#7

Hello @Krischan, please specify OS of the machine where ONLYOFFICE Desktop Editors are installed and specify also the version of Desktop application. This works on the latest version by us, please see this screenshot.


#8

Strange, will recheck. I tested it on an Ubuntu18.04 with the .deb version.


#9

OK, I checked again and it does seem to somwhat remember it. However when I put in the full URL with Https:// it only remembers the http: and not the full domain it seems.

Also on small screens (1280x800) you can’t see the edit option on the far right of the saved entry.

Thanks for looking into it :slight_smile:


#10

I’m using MACos, desktop edition are 5.22 ( 286 ) version.
The Onlyoffice server, in nextcloud work perfecly ( very goooood ) but the desktop show an error : timeout

The url of cloud are "https… "

( Sorry for may bad english )


#11

@Krischan, please try to enter only domain name of your Nextcloud without http:// or https://.

We will check the issue you described when working on the small screen.

@Cayetano_Gomez, please send us the screenshot of the error.


#12

Hi ,

Using url, without http or https :

imagen.png

Whith out path

image.png

Whith complete url :

imagen.png

If you want a user to do tests, I have no problem.

#13

Hello, I have the exact same issue as Cayetano_Gomez, was wondering if it had been resolved.


#14

Hello @Cayetano_Gomez, @edgeofthex, we are performing some tests on our side to detect the reason of the issue.

@edgeofthex, please specify if you also have an address of your Nextcloud instance like this: https://nextcloud_address/nextcloud


#15

Hello!!!

In previous screen captures I’m test this opcion, an does not work (see capture )

Regards,

Cayetano


#16

Hello Alexander,

Thanks for the reply. My Nextcloud url is https://marcloud.org/nextcloud.


#17

@Cayetano_Gomez, @edgeofthex, we found a bug in the current version of Desktop Editors, which does not allow to connect Nextcloud/ownCloud accounts when the address contains additional catalogue, like /nextcloud. The issue will be fixed in the next version of the app.


#18

Hi !

If I can help something, or need some proof, count on me.
If you want an account in my NextCloud, without problems ...

Regards,

Cayetano


#19

@Krischan, could you please send us a screenshot of incorrect displaying of the interface. We tried to use the mentioned screen resolution, but everything displays correctly.

Also on small screens (1280x800) you can’t see the edit option on the far right of the saved entry.


#20

Ah, maybe I was mistaken an removing a cloud only works with right-click. I remember there where 3 dots on the right hand side as a menu before?

But I still got the issue with the Snap and .deb version that I can add a nextcloud with or without the https:// in front and all it shows in the list is “https:” and not the actual cloud URL.