ONLYOFFICE cannot be reached - SSL changes

Installed Nextcloud on a Cloud Server from an image. Everything went fine, OnlyOffice was running.
After activitating SSL and installing the certificates and key, Nextcloud is still available but I can’t connect to OnlyOffice.
Already tried to disable/enable OnlyOffice and Community Document Server.
Trying to open existing documents killed them. They are empty now and even downloading them from Nextcloud or directly with sftp doesn’t change this.
OS: CentOS 7
Message from browser console: “Mixed Content: The page at ‘https://mydomain/index.php/apps/onlyoffice/21?filePath=%2FDocuments%2FExample.odt’ was loaded over HTTPS, but requested an insecure script ‘http://mydomain/index.php/apps/documentserver_community/web-apps/apps/api/documents/api.js’. This request has been blocked; the content must be served over HTTPS.”
Any ideas? I’m sure it has to do with the activiation of SSL but no idea how to fix it.
Thanks
Paul

Some users claimed removing (not disabling) and reinstalling the Connector can fix those issues…

Thanks for the tipp.
Result after removing and attempt to download and enable it:
“cURL error 28: Operation timed out after 30000 milliseconds with 9608764 out of 315849196 bytes received (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)”
Not much better :wink:

Downloaded the community document server manually and put it in the apps folder with ftp.
That solved the cURL problem :wink:
The main problem was fixed in the setup of OnlyOffice connector: You have to change the Document Editing Service address. This is not changed automatically when you switch from HTTP to HTTPS on the server

How did you download community document server manually and what is the folder.

Onlyoffice was working after installing on ip. Changing to domain and activate SSL make it inoperational

1 Like

At first try to remove the community document server (CDS) and disable the OnlyOffice Connector in the Apps manager.
Then install CDS and enable it, enable OnlyOffice Connector and go to the OnlyOffice Settings. There you can set the “Document Editing Service” address to the HTTPS URL similiar to this entry “https://yourserver.domain/index.php/apps/documentserver_community/”.
If you have problems downloading/installing the CDS get the newest version from here: https://github.com/nextcloud/documentserver_community/releases/download/v0.1.5/documentserver_community.tar.gz

I was missing the index.php part
With that i got: Error when trying to connect (Bad healthcheck status)

But now uninstalling and reinstalling it it worked.

Thank you! Paul

1 Like