Onlyoffice can not download Nextcloud 22 file error

After the update from 21 to 22 we get errors on all NC installations when the Onlyoffice server is connected. Onlyoffice works and is shown. But the system is not able to download the NC file. Clicking OK to go back does not work either.
The security is 100% of both NC and Onlyoffice.
What causes the file not to be uploaded to the editor?
As far as I could find, it looks like a javascript problem to execute the download. I could not find any setting in the webservers that should block execution. So I think it is in the Nextcloud connector app for Onlyoffice.

Please help me out…

ich habe das selbe Problem und bräuchte dringend Hilfe.
Auch der Support meines Providers hat geschaut, konnte das Problem aber auch nicht lokalisieren.
Kann jemand helfen?


A certified Red Hat Linux expert came to the conclusion that is is a softwareproblem in DSM7. For me it is also urgent problem, therfore I hired a consultant.

Are there some errors in the nextcloud log? Like connection timeout or somethink like that?
Where is OnlyOffice running? Docker on the local machine? What is the proxy configuration?

NC does not log anything about this.
OnlyOffice is running on a Debian 10 machine in a container.

But I solved it.
NC needs a more recent version of OnlyOffice. Look at my answer in DocumentServer not working - #3 by Hendrik
to see what I did to solve the problem.

So it had nothing to do with the Synology update to DSM7. That NC installation works now also again.