Onlyoffice 404 error

I’ve installed nextcloud VM (v17) and didnt configure onlyoffice during installation.

However i added the app and when i put the URL for my onlyoffice installation, i get this error

{“reqId”:“rLc6QkSf91RfEnAHbQTF”,“level”:3,“time”:“2019-11-24T05:00:02-10:00”,“remoteAddr”:“”,“user”:“johndoe”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/apps/onlyoffice/ajax/settings/address",“message”:“HealthcheckRequest on check error: Client error: GET resulted in a 404 Not Found response:\n\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

(truncated…)\n”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0”,“version”:“”,“id”:“5dda9af5eba9a”}

[onlyoffice] Error: HealthcheckRequest on check error: Client error: GET https://foo.comt/onlyofficeds/healthcheck resulted in a 404 Not Found response:

404 Not Found

404 Not Found


PUT /apps/onlyoffice/ajax/settings/address
from by johndoe at 2019-11-24T05:00:02-10:00

However i can access both the


& returns “true” from a browser without any issues

i tried adding

‘onlyoffice’ =>
array (
‘verify_peer_off’ =>TRUE,

but still no luck.

Both the servers are running using a valid wildcard cert

Both are running in an internal network (NAT). Both has FQDNs pointed correctly

Attaching screenshot of working onlyoffice pages

No errors on Apache logs