Older MacOS client strange problem


I run MacOS 11.7.10. Highest update my old iMac can handle. I use the legacy NextCloud client. But:

I got a message for an update and I clicked it. Now my old client is gone and the update only works on MacOS 12.0 and higher.

So I downloaded the legacy client but Apple refuses to open the package because the developer can’t be verified.

So I lost all connections to my servers, except for the browser.
What to do?

Yours, Berend

Same here (iMac 5K late 2014). If I remove the Nextcloud.app in the /Applications folder I can successfully install the legacy app by doing a right/ctrl-click on the installer and selecting “open”.

But now I have two problems: On start the app issues a push notification that there’s a new version (should know better that it is the latest version of the intentionally installed legacy version) and then crashes some seconds later, only to be automatically restarted again. And again. And again…

While typing this I had to click dozens of times into the text field in order to reset the keyboard focus here. Quitting the app manually does not help as it is restarted again by the system. I need to remove or rename the app to prevent the restart cycle.

Needless to say I now have a massive problem working with my files without a usable Nextcloud client.

PS: I now have tried the 2.6.2 version also, same effects.
PPS: Same for an old 2.5.1 I had laying around in my Downloads folder. I start to wonder if it is the driver or the local files.

Same here.
macOS 11.7.10, Intel Mac.
Last working version 3.9.1

I don’t have the restart issues but my NextCloud logo is vanished from the menubar so I can’t alter settings or check if the sync is working.
What happened that this is so mashed up suddenly?

Can’t even check which version I installed!

Helge: I downloaded and installed the version 3.9.1 you mentioned and that one is working as it should! Thanks for this.