Office Online Server Integration with NextCloud Configuration

Nextcloud Details
Nextcloud version: 19.0.3
Operating system: Ubuntu Server 20.04.01
Nginx: nginx/1.18.0 (Ubuntu)
PHP: 7.4.3

Office Online Server
Windows Server: 2012 R2 latest updates installed
Office Online Server: 16.0.10338.20039

Now I am having the following problem on Next Cloud while trying to open any file (NEW/OLD) on NextCloud being open with Office Online Server.


Thank you in advance for any help on getting this problem solved.


The following helped me:

  1. Certificates must be valid for nextcloud and office online
  2. Use the article to set up the office online

A bit late, but might be useful for somebody:

  1. Make sure you install OOS as supposed to - there are many guides on the internet, but make sure you install it on WS2016 (WS2019 is not planned to be supported at all).
  2. Configure the NC to OOS integration using the NC app
  3. Install the latest CU for OOS, following the official OOS update procedure!
  4. Issue certificates for the OOS and the NC servers - Let’s Encrypt are working fine
  5. Follow the guidelines here on how to enable TLS 1.2 on the OOS machine (or read below):
  • For all servers, make sure Microsoft Security Advisory 2960358 has been deployed.

  • For systems running .NET 4.6, save the below text as enable-tls1-2.reg and import it into the server.

Windows Registry Editor Version 5.00



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\PCT 1.0]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\PCT 1.0\Server]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Server]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0\Server]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]
  • Reboot the OOS server
    I can confirm that after these steps, the rendering of office documents kicked in flawlessly. Should you need additional troubleshooting, you can have a look at the ULS logs of OOS (found in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS), using ULS Deobfuscator or other ULS viewer.

Good luck!