Odroid N2+ Debian bullseye

Trying to set up NCP on a odroid N2+
Since there’s no Img, I’ve set up Bullseye:

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 11 (bullseye)
Release: 11
Codename: bullseye

Running the curl script install.sh throws out some errors / fails
last one is:

Failed to disable unit: Unit file smartd.service does not exist.

and an incomplete nextcloud installation.
any ideas? is odroid N2+ unsupported?

maybe this should tell me something?

Installing Nextcloud 24.0.5…
Creating possible missing Directories
chmod Files and Directories
chown Directories
chmod/chown .htaccess
PHP Warning: include(/var/www/nextcloud/config/config.php): Failed to open stream: No such file or directory in Comman>PHP Warning: include(): Failed opening ‘/var/www/nextcloud/config/config.php’ for inclusion (include_path='.:/usr/shar>PHP Warning: Undefined variable $CONFIG in Command line code on line 1
PHP Warning: Trying to access array offset on value of type null in Command line code on line 1
PHP Warning: Undefined variable $CONFIG in Command line code on line 1
PHP Warning: Trying to access array offset on value of type null in Command line code on line 1

this is the webpage after install-script :


I think this means “incomplete” or no DB?

I got no clue where to start troubleshooting

this is reproduceable…

also getting this when using the common ncp commands:

root@odroidn2:~# ncp-config
cat: /usr/local/etc/ncp-version: No such file or directory
cat: /usr/local/etc/ncp-version: No such file or directory

I’m wondering if noone but me tries to setup nextcloudpi through the script on a odroid N2+
:question:

Script works on:
Armbian_22.02.1_Odroidn2_bullseye_current_5.10.102

Don’t try to install nextcloudpi by the script on:
Armbian_22.08.7_Odroidn2_bullseye_current_5.19.17
Armbian_22.11.1_Odroidn2_bullseye_current_5.19.17