Odroid HC1 with SSD - Questions from a newbie


I am running a fresh installation of Nextcloudpi on an Odroid HC1. I can connect to it via browser, can see the interface and everything seems to be working fine. The image I used is the NextCloudPi version from here. After installation, I did the update and the running version is now 16.0.4.

There are some basic questions I have that I cannot figure out the answers for by the documentation provided. I know they probably seem trivial to most here, but I thought I’d try asking anyway. Here they are:

After setting up my Locale (UK), the time is off (-1hr) and I can’t find an option to adjust it for Summer Time. Is there such an option somewhere?

I am using a small SSD with the Odroid HC1. Do I need to pre-format it before connecting it to the Odroid, or can it be formatted from within Nextcloudpi?

I can’t figure out how to make the SSD become the main storage media from where all Nextcloud will be running I have read the instructions, WiKi etc, but I can only find directions for a USB drive and not for a connected SSD, so I don’t know where to start from.

I don’t even know if the SSD has been mounted, I don’t even know if Nextcloudpi can actually “see” the SSD or if it is currenty using only the microSD card’s storage space. Where would I see that?

I can’t find a way to check the remaining disk space of the storage currently used. I can see in the Personal Info section that I am using 6.3MB, which makes me think only the microSD card is used, but nothing for the SSD. That’s why I’m not sure whether Nextcloud can see the SSD at all.

I can’t figure out how to SSH to the Odroid. I have tried PuTTy with the Odroid’s IP address and port 22 but the page comes out completely black.

Under the Security & setup warnings section, I can see a warning saying:

There are some warnings regarding your setup.

This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them.

Please double check the installation guides, and check for any errors or warnings in the log.

I click on the Installation Guides link, but there’s nothing there about imagick. Quite lost on how to proceed.

Apologies for the newbie questions, I am trying to figure out all this which is very new to me and feel a bit out of my depth. Thank you in advance.

Most of the answers to your questions can be found in NCP’s documentation and/or NC’s documentation
You can also search this forum to search for the topics you mentioned, as some have very likely been answered already.

  1. run

sudo dpkg-reconfigure tzdata

to select and set your timezone

2 . Yes, look at nc-format
3. and 4. Use nc-automount and nc-datadir
5. run

df -h

  1. Enable ssh
  2. You can safely ignore that warning, imagick seems to have some vulnerability and has been removed by NC Devs.
1 Like

Thank you for your reply Oliver.

Did as said, but on the Locale in NC Panel it still shows the wrong time, even though I set it up correctly via SSH and it showed up correctly there.

Tried nc-format. The system started formatting the USB disk (which I assume is the SATA SSD), then got a message that said there is a I/O error and stopped. I know the SSD is in perfect working order. Now I can’t load the NCP panel at all (browser keeps attempting to connect to NCP panel but it can’t). Also, I now cannot connect to NC panel either, even though I can still connect via SSH.

3 and 4.
I couldn’t do that because of 2 above.

Done and it worked, thanks.

Done and it worked, thanks.

Any ideas on what I did wrong in 2?

I setup odroid hc1 like you some time ago. You have to prepare all things before first time you visit your nextcloud instance.

Ok, changed the SSD with a bigger one of a different brand just to make sure it wasn’t the disk’s fault.
Now I am doing the format through the NCP interface and choosing the defaults for everything.
Once the format is finished, the nc automount is already activated. the nc-datadir is asking for a directory. I am using the default but I get an error that the folder doesn’t exist.

I’ve tried re-writing the image file to the microSD and re-booting so many times, I am just getting frustrated of it now. Isn’t there somewhere a step-by-step guide for newbies on how to do this on an Odroid HC1/HC2 with a drive attached to it? I searched and found all sorts of guides on how to install NC on various distros but nothing for NCP on the specific Odroid with the specific setup (a single drive attached to it).

just go through the wizard

Hey there,

a little bit OT but I am interested in getting a HC1 with SSD for building a NAS here in my office. But the Nextcloud of course should be accessible from anywhere. What’s the performance? Is it snappy synching files and folders when outside the own WiFi? When sharing links of videos with others, is this setup capable of streaming 1GB of video material?

The office has a DSL connection, 50MBits down / 10MBit up. Would this setup be enough for a nicely working cloud or is shared hosting (where I actually am) the better option at the end? Actually I find the nextcloud on my provider somewhat slow that’s what I wanted to get rid of :wink: