Occ upgrade - "JIT compilation failed - No more memory"

I’ve upgraded Nextcloud from version 15 to 16 using apk in Alpine Linux. When I run occ upgrade, it’s failing with a lot of “no more memory” errors. I’ve included the full output below. I haven’t found any similar reported issues and as far as I can tell, I should have enough memory available.


I seems that this is defintely not* the case. Although you might have enough physical memory available in your server, you have to make sure that sufficient memory is assigned to your web server so that it can work as expected. Keep in mind that a web server usually needs more memory because it is used for several tasks in parallel.

Here you find detailed information about the Nextcloud requirements. At least 512MB is recommended to run your private server :wink:

I am running in a VM and have 512 MB allocated to it. I ran top in a separate session and re-ran occ upgrade and the majority of the 512 MB still shows as free memory. It drops by about 24 MB while it’s running.

I did a quick search and I’m not finding a specific setting to limit memory to nginx. I have tried raising the memory limit in my php.ini file to 512 MB as suggested but that doesn’t make a difference either.

I just upgraded from nc15 to nc17 and also started seeing this error. This is on a CentOS system with 16GB RAM (not in a VM). Turning off the PCRE JIT compiler (for me, this meant adding “pcre.jit=0” to my php.ini file) the errors went away, but I still don’t know what caused them.