Occ files:scan not working

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):


Nextcloud version (11.0.1):
Operating system and version (Ubuntu 16.04):
Apache or nginx version (Apache 2.4.25):
PHP version (7.0):
Is this the first time you’ve seen this error and can you replicate it?: I can replicate it every time I try to do a files:scan --all

The issue you are facing: “Home storage for user #### not writable
Make sure you’re running the scan command only as the user the web server runs as”

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!): <?php
$CONFIG = array (
‘instanceid’ => ‘ocneczm28hi0’,
‘passwordsalt’ => ‘#####’,
‘secret’ => ‘#####’,
‘trusted_domains’ =>
array (
0 => ‘#####’,
1 => ‘#####’,
2 => ‘#####.net’,
),
‘datadirectory’ => ‘/#####/#####/nc-data’,
‘overwrite.cli.url’ => ‘https://#####.net/nextcloud’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘11.0.1.2’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘oc_###’,
‘dbpassword’ => ‘#####’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘mail_smtpmode’ => ‘php’,
‘mail_smtphost’ => ‘smtp.#####.net’,
‘mail_from_address’ => ‘nextcloud’,
‘mail_domain’ => ‘#####.net’,
‘mail_smtpsecure’ => ‘ssl’,
‘mail_smtpport’ => ‘465’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘localhost’,
‘port’ => 6379,
),
‘appstore.experimental.enabled’ => true,
‘maintenance’ => false,
‘loglevel’ => 2,
‘theme’ => ‘’,
);

The output of your Apache/nginx/system log in /var/log/____:


Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

Do you use sudo to run the occ command with the webserver-user? Did you set the permissions of files and folders that the webserver-user is the owner?

Thank you for your response and I should have stated that, yes I am the web user and have proper permissions set.

No cigar yet with this and I have not had time to set down and work on it!