Nothing working again

Nextcloud version (eg, 18.0.2): 19.0.0.12
Operating system and version (eg, Ubuntu 20.04): Ubuntu Server 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.41 (Ubuntu)
PHP version (eg, 7.1): PHP 7.4.3 (cli)

The issue you are facing:
Nothing will work, I see no files


There is no Side menu by the logo

and login will not work

eveytime I try to login it sends me back to the login page with this url
https://cloud.sturtz.ml/login?redirect_url=/apps/files/

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Goto https://cloud.sturtz.ml
  2. Try to login

The output of your Nextcloud log in Admin > Logging:
It is too long to post here,
https://static.sturtz.ml/nextcloud.log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '__REMOVED__',
  'passwordsalt' => '__REMOVED__',
  'secret' => '__REMOVED__',
  'trusted_domains' => 
  array (
   0 => 'cloud.sturtz.ml',
  ),
  'datadirectory' => '/var/data',
  'dbtype' => 'mysql',
  'version' => '19.0.0.12',
  'overwrite.cli.url' => 'https://cloud.sturtz.ml',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'username',
  'dbpassword' => 'password',
  'installed' => true,
  'app_install_overwrite' => 
  array (
    0 => 'socialsharing_twitter',
    1 => 'socialsharing_email',
    2 => 'registration',
    3 => 'twofactor_email',
  ),
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'no.reply',
  'mail_domain' => 'sturtz.ml',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '__REMOVED__',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'no.reply@sturtz.ml',
  'mail_smtppassword' => '__REMOVED__',
  'htaccess.RewriteBase' => '/',
  'maintenance' => false,
);





The output of your Apache/nginx/system log in /var/log/____:

[Tue Jul 14 00:00:02.112339 2020] [ssl:warn] [pid 1029] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 14 00:00:02.113367 2020] [mpm_prefork:notice] [pid 1029] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
[Tue Jul 14 00:00:02.113377 2020] [core:notice] [pid 1029] AH00094: Command line: '/usr/sbin/apache2'
[Tue Jul 14 00:00:03.427119 2020] [mpm_prefork:notice] [pid 1029] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Tue Jul 14 00:00:03.513159 2020] [ssl:warn] [pid 1029] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 14 00:00:03.514234 2020] [mpm_prefork:notice] [pid 1029] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
[Tue Jul 14 00:00:03.514244 2020] [core:notice] [pid 1029] AH00094: Command line: '/usr/sbin/apache2'
[Tue Jul 14 00:00:36.934823 2020] [mpm_prefork:notice] [pid 1029] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Tue Jul 14 00:00:37.005742 2020] [ssl:warn] [pid 1029] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jul 14 00:00:37.006752 2020] [mpm_prefork:notice] [pid 1029] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
[Tue Jul 14 00:00:37.006762 2020] [core:notice] [pid 1029] AH00094: Command line: '/usr/sbin/apache2'

I wonder if this is related,
my main site https://sturtz.ml is down, are they related?

What can I do?

Yes, they are related if you run your Nextcloud on the Apache server that serves https://sturtz.ml. That one is up now, showing the default Apache page - but https://cloud.sturtz.ml is not responding, so I assume your Nexcloud is down.

There is something strange with your DNS registrations though.

I don’t speak DNS very well, but it seems to me that sturtz.ml has redundant registrations (different IP addresses on the same name). And cloud.sturtz.ml is somehow registered, or at least recognized with the same nameservers that holds information on sturtz.ml, but it doesn’t look right.

Here’s a dig for sturtz.ml
And here’s a dig for cloud.sturtz.ml

The end result is confusing:

Here’s my nslookup sturtz.ml

Non-authoritative answer:
Name:	sturtz.ml
Address: 172.67.158.64
Name:	sturtz.ml
Address: 104.27.160.251
Name:	sturtz.ml
Address: 104.27.161.251
Name:	sturtz.ml
Address: 2606:4700:3034::681b:a1fb
Name:	sturtz.ml
Address: 2606:4700:3032::ac43:9e40
Name:	sturtz.ml
Address: 2606:4700:3036::681b:a0fb

All three IPv4 adresses answers to ping. I don’t route IPv6, so I wouldn’t know about those.

And here’s my nslookup cloud.sturtz.ml

Non-authoritative answer:
Name:	cloud.sturtz.ml
Address: 2604:99c0:8:2f60:223:24ff:fe08:581f

So the cloud.sturz.ml has only a IPv6 address, not matching any of the addresses for sturtz.ml.

I don’t really understand this, but it looks like you should talk to your ISP. Maybe all is well, but it smells fishy to me.

1 Like

Thank you for your reply, I will look into it, I never thought to look into my DNS.

This just happened again after I got a error about the PHP memory limit
I set the memory limit to -1 in php.ini

I need to fix this

Check step 4 in this guide, for recommendations regarding PHP configuration:

I can only find a IPv6 DNS entry for cloud.sturtz.nl. Not really nice.

Name:    cloud.sturtz.ml
Address:  2604:99c0:8:2f60:223:24ff:fe08:581f

You can set “cloud.sturtz.ml” as Alias with CNAME to “sturtz.ml”.

What, I want cloud.sturtz.ml as my domain, not sturtz.ml
Sturtz.ml is my Search Engine

host sturtz.ml
sturtz.ml has address 172.67.158.64
sturtz.ml has address 104.27.161.251
sturtz.ml has address 104.27.160.251
sturtz.ml has IPv6 address 2606:4700:3036::681b:a0fb
sturtz.ml has IPv6 address 2606:4700:3034::681b:a1fb
sturtz.ml has IPv6 address 2606:4700:3032::ac43:9e40
sturtz.ml mail is handled by 10 mx.yandex.net.

host cloud.sturtz.ml
cloud.sturtz.ml has IPv6 address 2604:99c0:8:2f60:223:24ff:fe08:581f

I think you missed some DNS configuration for cloud.sturtz.ml .
Set CNAME cloud.sturtz.ml to sturtz.ml if you want to use it on the same ip/server.

ok? I have no clue what a CFName is/?

How do I do that on Cloudflare?

No idea. But i think Cloudflare oder CDN is no good idea for Nextcloud.

Cloudflare oder CDN ???

The correct word is “or”. Sorry.

what is a CDN

Did I do it right?

With Cloudflare (or CDN or not) you are using different servers or ip addresses for your service (e.g webservice).
Is it nessessary to use this for your nextcloud?
Do you have different server, networks, … like your web service for nextcloud?
What about apache2/nginx / nextcloud and data/database - backend?

1 Like

I have everything on the same server, and I am using apache2, with mysql and php7.4